PJSIP/anonymous-0000000nn


(Wey2Go) #1

I have inbound SIP trunks. All extensions are PJSIP.

In Asterisk SIP Settings - Security Settings, if I do not “Allow Anonymous Inbound SIP Calls” and “Allow SIP Guests”, all inbound calls will not be successfully picked up by the FreePBX.

As soon as I changed it to “Yes”, inbound calls via our SIP Trunks work as expected.

In Call Detail, I can see the “Channel Name” showing as PJSIP/anonymous-0000000nn where nn are numbers. with context = from-sip-external

How to “make” inbound calls from the registered SIP trunks not an anymous?

Thanks.

Obviously, this is a security concern.


(Tom Ray) #2

You don’t have the trunk setup to accept/match the providers IPs. You need to add all the IPs they could send calls from.


#3

Are your trunks PJSIP or chan_sip?


(Wey2Go) #4

Trunks are chan_sip.

Now, I configured some PJSIP trunks (basically the same providers) but left them disabled, the issue to have gone away.


(Wey2Go) #5

Sorry, where in FreePBX?


#6

Your trunk provider is sending the traffic to you on the port where PJSIP is listening.

My suggestion is to be done with chan_sip altogether and remove it from your configuration, using only PJSIP for both phones and trunks.

It is not. It is just a misconfiguration, and best solved in my opinion by simplifying.