PJSIP and the "Dial" field in advanced tab

Here’s the scenario. Users have both a physical phone as well as Zulu phone. When they are set up in the pbx as PJSIP the “Dial” field under advanced tab displays something like “PJSIP/82404”.

This is fine and both phones ring when you call the extension. Here’s my problem.

We also use iSymphony. If I want iSymphony to work with Zulu I have to go into the extension inside of iSymphony admin panel and change the device to “PJSIP/9082404”. That works just fine but since we sync with FreePBX every time that someone makes a change in the pbx and hits “apply config” it sets it back to “PJSIP/82404” in iSymphony.

I can fix this problem by changing the field “Dial” on the pbx under advanced tab to “PJSIP/9082404” which keeps iSymphony set up correctly. The issue is when I change that field to include “90” in the extension that renders their physical phone useless. It doesn’t ring anymore.

Is there anything I can do so that both phones ring and it doesn’t override the “90” change in iSymphony?



Lorne, making that change on the PBX side doesn’t break anything (both zulu and hard phone ring) but setting the peer in iSymphony to “PJSIP/82404&PJSIP/9082404” breaks it in iSymphony. Maybe I need to get a hold of iSymphony and see if there is a way to have multiple peers and then see if it breaks FreePBX.

1 Like

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.