Pickup Parked call on Aastra 6869


I can see parked calls in the Parking application, when I press “Dial” after selecting on I see
">s" on the screen for a split second then it says “call failed”

Any ideas?



I’m seeing this behavior on four different systems, Have you found a resolution to this problem? If I park a call and go to my web browser and hit the REST URL, you can see trailing “s” tacked onto all sorts of things. Example:

“dial”,“name”:“parkinglot_3s”,“display”:“s: CID:1602xxxxxxx (2 secs)”,“value”:“s”}

What the heck is that about? In extensions_additional.conf it’s parkinglot_3, not 3s. Methinks there is a typo somewhere that is causing this strange behavior.

I also have the same problem with Aastra 6863i and 6867i phones.

Anybody have any updates on this? REST Parking is still dead. I’m wondering what I paid for because this thing doesn’t work.

Support told me to rollback to a supported Asterisk (11). I was on 13.

I haven’t yet tried it

This is a bug with Asterisk 12 and 13 in RestApps as Asterisk changed all the manager settings. Open a bug report at issues.freepbx.org and we will add it to our list of things in Asterisk 13 that need changing in FreePBX

Would this also be causing voicemails not to playback via the voicemail app? The voicemail shows, and when I hit play the screen changes and shows what it should if the message was playing, but the line is not picked up to play the message. If this wouldn’t be the same issue, I’ll open a separate topic/issue. I’m running 6.12.65-24 asterisk 13, aastra phones (happens with multiple models) running pjsip on port 5069.

I opened a bug http://issues.freepbx.org/browse/FREEPBX-8585

Tony, is the previously mentioned bug filing adequate for this issue to be worked on? I want to track the progress of this bug so if you could confirm that for me, I’d appreciate it. Also, I notice the bug is categorized as “minor”. Do you think that’s appropriate for a feature that’s completely non-functional?

Its Minor as its not something we support currently meaning none of the Rest Apps or anything in FreePBX takes a stance to use Asterisk 12/13. We warn users its Beta.

I thought freepbx 12 and asterisk 12 weren’t beta products anymore. And if bugs this severe are going to be considered minor, then you should have the option to use restapps with these releases free of charge.

You are confusing FreePBX 12 with Asterisk 12. FreePBX 12 is stable but Asterisk 12/13 is not. The ISO at install time says under Asterisk 13 its beta and if you use the asterisk switch version scripts it also warns you Asterisk 13 is not for production use.

I wonder how I got confused when your versioning went from 5 to 6 to 12. A mystery is afoot! You still didn’t address the fact that if you don’t do anything about bugs in pre-release products, they should be free.

No our versioning is not 5 or 6. That is the core OS versioning. I think you are confusing FreePBX Distro which uses FreePBX GUI.

No we do fix bugs in pre-release. As we stated numerous times please open bug reports and someone will look into them but Commercial Modules are only supported on STABLE releases.

In what I consider to be a nice little bit of irony, let me help you…

You should really take that CEO label off your profile here. Your behavior is not becoming of somebody who is interested in the financial success of a corporation. Calling yourself a technician or similar would be beneficial because anybody who views your responses would just assume that Schmoozecom doesn’t have very high, or for that matter any, standards for who they hire into customer service or technical support positions.

But, you know, speaking of help, don’t go out of your way, or even bother doing anything at all. I’ve come to the conclusion from reading your responses that I can bark all day long and it won’t change a thing. These problems will never be solved until your leisure allows it. I’m going to rebuild all my systems from the ground up and steer clear of FreePBX. I know this solution isn’t for everybody so I won’t pretend that I’ve stumbled across some great secret. The fact is that FreePBX is a magnificent piece of software and most likely is solely responsible for the health of the open-source PBX market as it exists today.

It’s just a shame that one of their officers concerns himself with matters that would better fit a person more customer service training.

I’ve never mentioned it before, but I think you should know that for many years, going way back to the birth of Trixbox, I avoided Asterisk-based PBX solutions in favor of Cisco CallManager because of an individual going by the moniker “SkykingOH”. Whenever I’d Google something about FreePBX, his name would constantly appear and the way he treated people immediately turned me off of anything related to Asterisk. I don’t think anybody but SkykingOH would be upset if you went back through your website and completely scrubbed his content from it. Only good things could come of it.

I’m out. Good luck.

I personally would have to stongly disagree with you @natelee123 , Both Scott and Tony are among the few who understand the FreePBX ecosystem well enough to help people like you (the self-entitled ones who don’t actually read or understand anything and need spoon-feeding). There is nothing here he said that could possibly cause offense to a reasonable person, Asterisk 12/13 is BETA, if you don’t understand what that means, I will help you . . . You find a bug, you report it in the relevant place, not here. Get your checkbook out with Cisco! and please feel free to continue to bark at the moon :wink:


Wow not really sure what I said but I was giving you direction on how to report a bug.

@natelee123 … so you joined just over a month ago and have made 7 posts and each time you have antagonized the CEO and one of the highest contributors to this project using a combination of software that is clearly labeled as not for production.
Well done tiger …
The obvious solution would be 1 line of code to roll back to Asterisk 11 on FreePBX12 and play niceley with everyone else … oh well

@clifforg, did rolling back work for you? Maybe letting other users know if things work would make life easier for others.

So just for clarification. You are complaining about a bug that was found and reported in the bug tracker finally on Jan 16th on a Beta release.

This issue was resolved yesterday as you can see in the ticket, http://issues.freepbx.org/browse/FREEPBX-8585

I would say that is a great response on fixing things in a “No Production Ready” version of Asterisk that we want users testing with and reporting issues back so they can get fixed.

And this thread is closed. The solution was reported as a bug and it was fixed in 17 days. Not too shabby. As for the rest of the thread. I think it got a little out of hand and I’d hate for it to continue and for someone to search the name “natelee123” and turn away from FreePBX because of it. We like to foster a positive environment. Considering two users (who don’t work for Schmoozecom/Sangoma, and one of them is one of our most critical supporters) expressed opposition to “natelee123” I think this thread has run it’s course and will serve no other purpose if left open other than to argue about how someone feels they were mistreated.

Thanks for using FreePBX!