PHP Parse Error after updates

I just ran my module updates and after all of my phones went offline. Any time I try to do any fwconsole commands I get the following error:

PHP Parse error: syntax error, unexpected ‘[’, expecting ‘)’ in /var/www/html/admin/modules/sysadmin/Console/Sysadmin.class.php on line 240
Whoops\Exception\ErrorException: syntax error, unexpected ‘[’, expecting ‘)’ in file /var/www/html/admin/modules/sysadmin/Console/Sysadmin.class.php on line 240
Stack trace:

  1. () /var/www/html/admin/modules/sysadmin/Console/Sysadmin.class.php:240

Anyone have any thoughts on how to fix this? We are dead in the water right now.

FreePBX Firmware: 10.13.66-22
Current Asterisk Version: 13.19.1

Ticket Number?

Can probably be solved by downgrading either the Framework or SysAdmin modules.

Tried that. When I do a reload I get the following error:

exit: 1
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
Exception: Unable to connect to Asterisk through the CLI in file /var/lib/asterisk/bin/retrieve_conf on line 41
Stack trace:

  1. Exception->() /var/lib/asterisk/bin/retrieve_conf:41

Okay so I seem to have fixed the issue.

Went into the Asterisk CLI and did a “core reload”. After that I ran “fwconsole restart” and once FPBX was restarted the issue seems to have gone away.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.