PHP errors after update

after updating to freepbx 16 i get a lot of errors from the CLI and the web interface regarding acpu.so

PHP Warning: PHP Startup: Unable to load dynamic library 'apcu.so' (tried: /usr/lib64/php/modules/apcu.so (/usr/lib64/php/modules/apcu.so: cannot open shared object file: No such file or directory), /usr/lib64/php/modules/apcu.so.so (/usr/lib64/php/modules/apcu.so.so: cannot open shared object file: No such file or directory)) in Unknown on line 0

our phone system is online 24/7 and I don’t really have the opportunity to re-install from scratch. any suggestions to fix this issue would be appreciated.

i have tried to do yum update. but I get the following error:

[[email protected] ~]# yum update
Loaded plugins: fastestmirror, versionlock
Loading mirror speeds from cached hostfile
 * remi-safe: mirror.netweaver.uk
Resolving Dependencies
--> Running transaction check
---> Package gd-last.x86_64 0:2.3.2-1.el7.remi will be obsoleted
--> Processing Dependency: gd-last(x86-64) >= 2.1.1 for package: php-gd-7.4.16-1.el7.remi.x86_64
--> Processing Dependency: libgd.so.3()(64bit) for package: php-gd-7.4.16-1.el7.remi.x86_64
---> Package gd3php.x86_64 0:2.3.3-7.el7.remi will be obsoleting
---> Package libzip5.x86_64 0:1.7.3-1.el7.remi will be updated
---> Package libzip5.x86_64 0:1.9.2-3.el7.remi will be an update
---> Package oniguruma5php.x86_64 0:6.9.6-1.el7.remi will be updated
---> Package oniguruma5php.x86_64 0:6.9.8-1.el7.remi will be an update
--> Finished Dependency Resolution
Error: Package: php-gd-7.4.16-1.el7.remi.x86_64 (@sng-sng7php74/7-8.2003.3.el7.sangoma)
           Requires: libgd.so.3()(64bit)
           Removing: gd-last-2.3.2-1.el7.remi.x86_64 (@sng-sng7php74/7-8.2003.3.el7.sangoma)
               libgd.so.3()(64bit)
           Obsoleted By: gd3php-2.3.3-7.el7.remi.x86_64 (remi-safe)
              ~libgd.so.103()(64bit)
Error: Package: php-gd-7.4.16-1.el7.remi.x86_64 (@sng-sng7php74/7-8.2003.3.el7.sangoma)
           Requires: gd-last(x86-64) >= 2.1.1
           Removing: gd-last-2.3.2-1.el7.remi.x86_64 (@sng-sng7php74/7-8.2003.3.el7.sangoma)
               gd-last(x86-64) = 2.3.2-1.el7.remi
           Obsoleted By: gd3php-2.3.3-7.el7.remi.x86_64 (remi-safe)
               Not found
 You could try using --skip-broken to work around the problem

Please check if you have acpu old php lib.

yum list installed php56w-pecl-apcu

If yes then please remove this rpm.

legend thankyou. it appears to have fixed it right up. no more errors on pages.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.