PHP Component Zend Optimizer is required

Not sure if anyone has run into this, ll of a sudden I am getting the error below when updating modules:

◦PHP Component Zend Optimizer is required but missing from you PHP installation.
Please try again after the dependencies have been installed.

I am on Asterisk 1.8.2 and freepbx 2.9.0.7.

After some research it looks like it maybe related to a change the Zend PHP modules after a PHP upgrade. I think the issue could have occured when a yum update was done.

However, ultimatly this maybe something that needs to be resolved within FreePbx in order to support. My PHP version is 5.3.6.

I have the same problem here. Cannot upgrade any module anymore.
How can I (re)install PHP Component Zend Optimizer?

thanks.

The only reason you would have the dependency in zend is if you had installed any of the Commercial modules from FreePBX that require zend to run.

Ok, so I uninstalled the modules that were causing the issue… great, now I don’t get any errors. However, what if I wanted some of those modules? I personally do not however, I’m sure someone out there would wan them.

Those modules do not support PHP 5.3 at this time. The 2.10 versions of the module will support PHP 5.3 or 5.2 and that is why Zend would not install as Zend Optimizer only works with 5.2 or older PHP

Perfect, thanks.

Dear
on the same subject am trying the below
[email protected]:/var/lib/asterisk/agi-bin# sudo -u asterisk /var/lib/asterisk/bin/module_admin install sysadmin
The following error(s) occured:

  • PHP Component Zend Optimizer is required but missing from you PHP installation.
  • File /usr/sbin/incrond must exist.

so how can i proceed ?
BR

rfarchoukh try this, just remember commercial modules may not work on hand built or non supported Distros.

http://wiki.freepbx.org/display/FCM/Asterisk+Now+and+Other+FreePBX+System#AsteriskNowandOtherFreePBXSystem-InstallRPMstoenableFreePBXCommercialModuleSupport.

Thank you Preston for your fast reply
your last comment didn’t work for me as i have the below system
ubuntu OS
FreePBx2.9
asterix1.8
appreciate any advise…
thank you
ramzi

Most of the commercial modules require at least FreePBX 2.10 to be supported.

thank you for your recommendaiion
so i have upgrade my FreePbx to 2.10
but still have the same issue :s
"PHP Component Zend Guard Loader is required but missing from you PHP installation"
in addition after i the upgrade took place i get new error message showed at teh system status
"Could not reload the FOP operator panel server using killall -HUP op_server.pl."
Br
Ramzi

You need to follow the link Preston sent you and figure out how to install the dependencies in Ununtu via apt-get.