Phones unreachable from outside

A few days ago our Polycom phones stopped being able to receive calls from outside. We can call out and each other’s extensions just fine, but if anyone tries to call in it rings six times then hangs up.

The person who originally set up our PBX system and most of the phones left five months ago, but never told any of us how anything works. I’ve tried rebooting the phone system from the website, but that hasn’t fixed anything. I’ve updated a few of the modules that I thought might be the issue, but that didn’t help either.

We’re running |PBX Firmware: 2.210.62-3 and PBX Service Pack: 1.0.0.0.

Any help would be really appreciated.

That version went end of life 7? 8? years ago and is long past due for an upgrade. Beyond your immediate need to get phones working, you need a plan get get on a supportable system. There is a tool for migrating settings to a new install: https://wiki.freepbx.org/display/PPS/Elastix+and+PBXinaFlash+to+FreePBX+Distro+Conversion+Tool

I’m not surprised it’s that old. The previous director wasn’t keen on updating/upgrading things. I do thank you for the link for upgrading. I suppose you don’t have any idea what’s wrong with our phones, do you?

The log file is /var/log/asterisk/full and is kept for about 24 hours (before logrotate starts up a new file).

Look through the file and find an incoming call that isn’t being answered. If you need help interpreting the file, post the extract here and we can look at it and give you some ideas.

There are only 200 things it could be. The logs will narrow that down pretty quickly.

Okay. It won’t be until Monday, but I’ll try and get into the actual computer running this. I know it’s some Linux, but other than that I know nothing about it. Can I putty into it, or do I need to actually be at the machine? Or is that dependent on the OS itself?

If SSH is allowed on your machine, then yes.

Okay, so I managed to get into the machine and I have copies of all of the “full” files. Now I have the problem of not being able to paste the contents of the most recent file, because it’s too big even for Pastebin.

Paste just the range of entries covering a failing attempted call at pastebin.freepbx.org and post the link here.

Thanks, Stewart1. Here’ the link with what I’m pretty sure is my test call. I know I dialed the number at 12:06 from my cell phone. http://pastebin.freepbx.org/view/2df06a59

[fixed link - mod]

Has anyone had a chance to look at that log? Do I need to run another test and post another excerpt?

Make another call that failed , look in the log for one recognizable line that is the failed call ( pretend it is 13400), from bash :-

grep "VERBOSE\[13400\]" /var/log/asterisk/full

paste that output.

I took a brief look and the log was hard to read because almost all entries were duplicated. Take a look if your logging config somehow mentions the same file twice.
https://wiki.asterisk.org/wiki/display/AST/Logging+Configuration

Also, there are two internal calls (to 5235 and 5213) and an outgoing call with prefix 8 to a VZW phone in Auburn, MA. No sign of any incoming calls.

I just tried calling three of our numbers and it hung up after six rings each time. Here’s a copy of the log with duplicate entries removed. pastebin.
freepbx.org/view/922dc42b

you have two logger entries logging to /var/log/full, from the asterisk cli

logger show channels

Disable or fix your “restricted routes” module.

paste the output of

grep "VERBOSE\[23197\]" /var/log/asterisk/full

I don’t see the “restricted routes” module in the Module Admin. It sounds familiar, but I can’t find the setting for it.

Well that is only for outgoing calls, how 'bout the ones your complaining about (inbound) and the rest of my post?

I thank you all for you help, but apparently the issue is now moot. We’re moving all of the phones to Gravis in the next day or two.

Out of curiosity though, could this be caused by a change in the company’s firewall?

Yup. Firewall or IP change would do it. SIP ALG probably causing that. UDP timeouts, missing port forwards.

I had a feeling that would be it. Our new “IT” department from the company that bought us last year is screwing around with the network trying to “fix” things and make things “more secure and to their standards”. They started adjusting the firewall and either set up a new one or directed our traffic to theirs a couple of weeks ago which I think is about the time that the phones stopped working.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.