Phones not Registering

Hi all - Having a major issue getting some phones to register on FreePBX 16 ( New Installation )

  1. Our FreePBX 15 server crashed so we Installed FreePBX 16 and it is up and running.
  2. We have 4 offices all have the same PFsense routers and VPNs and communication is no problem among them all - The system that crashed was working perfectly ( HD Failures crashed the server )
  3. We have mix of SNOMs and Polycoms ( Soundstation models)
  4. The “new” system is also working but for I cannot get a number of phones to register – especially the Polycoms. I can only configure them via their GUI from my main office - I do not have access to the physical phone. I cannot rely on the local users either.
  5. We are using only PJSIP - and on a test phone I ran the fwconsole commands to convert the phones to pjsip successfully. I have removed and replaced the extension a number of times and even tried a “No Password” option for a test. The phone / phones will not register.
    We DO have a few phones in each office that did register and are working fine. I have this issue mainly with the Polycom desk phones.
    I have limited experience with Wireshark - but in a capture I did see a 401 Not Authorized line on the problem phones. I also see [2022-05-20 17:45:48] NOTICE[14913]: res_pjsip/pjsip_distributor.c:676 log_failed_request: Request ‘REGISTER’ from ‘“Conference” sip:[email protected]’ failed for ‘’ (callid: [email protected]) - Failed to authenticate in the Asterisk CLI.

The phones in question were working on the previous server FreePBX 15 but I admit I had similar issues when we first installed it - I had to have some at the remote office sit at the phone and follow instructions to register them.

I hope someone can help me get thewse phones registered … I am also asking if there is a way to get into the phones configuration remotely without using the GUI?

Thank you

What port is PJSIP bound to? If it’s not 5060 you would receive that error.

1 Like

The phones are using Port 5060 – The server is listening on UDP 5060 and TCP 5061 The Firewalls are open to 5060 and 5061

I also noticed that 3 phones in one of my offices do not appear in “pjsip show endpoints” !! Their extensions have been created and the VoIP can PING their IPs but even the phones that DO appear as endpoints will not register. I do not have Endpoint Manager installed or know if that will make any difference.

I have one other observation that might help point to a solution…

I have 4 remote offices each with mulitple SNOM and PolyCom phones but my new FreePBX 16 VoIP server only registered 1 phone from each office. I cannot seem to get the remaining phones registered !

I been picking up articles and thought I saw one that suggested changing Endpoint Identifier Order but not mentioning to what order and how exactly to do that.

So …how do I test this and implement the change?

I have further information – I am able to register all our SNOM phones from any office without any issues, it is only the Polycoms ( various models) that will not register.

Has anyone else had an issue like this and, if so, how was it resolved??

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.