Phones constantly failing to the registration


(Alejandro) #1

Im having an issue once in a while my phones fails to reconnect or do the registration for no reason, I just reset the phone an is able to reconnect with no issues.
Why could cause this?
My ip phones are Fanvil X3S/X3SP
Any advice?


#2

You will need to provide a lot more info about your setup. Is freepbx on the same network as your phones? If not, is either freepbx and/or the phones behind a NAT device.


(Alejandro) #3

My pbx is in a VPS outside of my local network.
I have 4 phones but not all of them fail, it can be 3 of them working fine and for some reason one of them fails, sometimes all of them work properly for a week , all i do is reset the phone and they connect fine.
Any suggestions?


(Tom Ray) #4

Fix the NAT issues where the phones are. That’s what is causing your issue.


(Alejandro) #5

How I can do it? or how do I know if the issue is in my local network or the VPS?
This are my NAT settings on the pbx
NAT yes
IP configuration Static IP
OVerride External IP Mypublic ip address.


(Tom Ray) #6

You need to look at your router. The reason the phones just come up when you reboot them is because you’re causing a new request to be issued and this caused the firewall/NAT to open rules for that traffic to be handled by. When you can’t call them it’s because the NAT is no longer there or it’s going to the wrong destination.


(Alejandro) #7

I understand that you said fix the NAT but fix what a parameter open a port or do what?
All i can see in my router is a NAT parameter that is empty, My dhcp is disabled I managed with a windows server not with my router.
Can you please be more specific on how to fix it?


#8

It depends on your router. But you need to look for session timer parameters. If your particular router model doesn’t have any parameters related to session timers, then it might be necessary to change it for a more advanced router.


(Alejandro) #9

I will try with that.
Thank you…


#10

You may also want to check if your phone has a registration interval/timeout setting. If it’s much higher, a lower setting like 2 minutes could be worth trying.


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.