Phone updates work on S300 but not S305

I have two Sangoma phones sitting next to each other, an S300 and an S305. They are using the same EPM template and both phones work fine. They will also provision correctly via ZTP on HTTPS if I reset them to factory defaults. And they provision fine if I log in to the phones and tell it to provision now. There is no DHCP option for provisioning and all provisioning except HTTPS with username and password has been disabled.

However, only the S300 will provision when I push updates from the server (which is hosted and therefore not on the same network). I can also reboot the S300 from EPM. But the S305 will do neither.

In EPM Extension Mapping, the IP address of the S300 is the public IP where it is located (remember, hosted system). The S305 however shows it’s LAN address. I suspect this is telling me what the problem is but I’m not getting the message. BTW, these are pjsip.

I also updated both phones to the latest firmware; they were on 1.58 ( and now they are on 1.60 (

I’m betting this one will smack me in the face when someone points out the problem to me.

I’ve seen similar issues when provisioning these phones with a different Model (example: provisioning a S505 under a EPM Model S500)

Anyway, is EPM up to date?

EPM was a version or two behind. I updated it but it didn’t help. I’m thinking that the fact that the phone is showing registered as a local IP even though the system is hosted is trying to tell me the problem.

AFAIK: These EPM “Pushing” updates and reboot is a SIP Notify. So if the phone does not receive it, or the PBX is sending it to a local IP then that’s your answer.

Is that phone registered via VPN? Is NAT enabled?

VPN is not setup or active on the phone. Not sure about NAT. I don’t know where to look for pjsip, only chan sip. Where would check to see if NAT is enabled?

Settings > Asterisk SIP Settings > General Settings

External Address = Your PBX’s WAN IP
Local Networks = Only Local Networks from which the phones are registering against the PBX’s LAN IP.

If the info there is correct you may want to try adding these info under the Chan PJSIP Settings tab at the bottom.

Once updated and applied config, restart Asterisk

fwconsole restart

I’ve tried everything I can think of but I have to admit that I’m not sure what is correct. The system is hosted and the phones are here in my office. The S300 is working and shows the public IP of the office in Extension Mapping. The S305 is not working (EPM updates) and still shows the LAN address of the phone in Extension Mapping.

I tried adding the public IP/network of the office, the LAN IP/network, and then removing them all (Asterisk SIP Settings per your post). I restarted Asterisk and reset the phone to factory defaults each time.

I assume it’s PJSIP? Whatever extension number the S305 is mapped to, browse to Applications, Extensions and edit it, click advanced tab and ensure “Rewrite Contact” is set to yes.

1 Like

It was set to no, although I have no idea how it got that way. Setting it to yes fixed the problem.

So thank you for your help! Any additional insight or understanding you can share would be the cherry on top.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.