Phone stops dialing out if I change the extension

Hello, I am having a weird issue. I have freepbx setup on a local server. I have two s700 phones. I set them up with the extensions of 101 (and 102). Then I was told on a video to start your users at least at extension 200 or so as to not interfere with feature codes. So I can dial out on the phone no problem. It is set to 101. I create a new extension. Reconfigure the phone. Doesn’t matter what extension I change it to, I can not dail out. If I put it back to the original extension I had set it(101), it starts working again and I can dial out!

So obviously something is not updating when I set the new configuration, and thus new extension. I reboot the phone, it works fine, takes the new extension. but if that extension isnt 101, the phone wont work! What’s going on here???

If you are using the Class of Service or Extension Routes modules, you need to change their settings to permit calls from the new extension numbers. Or, if your Outbound Routes have values in the CallerID field of the Dial Patterns, you need to adjust them for the new extension numbers.

If none of the above, what do you hear when an outbound call fails? What appears in the Asterisk log?

IMO, it’s more important not to interfere with external numbers. For example, if your small (less than 20 extensions) system is in North America and you allow dialing 10-digit numbers: You can set the dial plan in the devices to place a call as soon as the last digit is dialed, without having to press ‘Send’ or ‘Dial’. So, if you dial 101, the phone places the call as soon as the third digit is entered.

However, you couldn’t do that with 201, since that is also an area code in New Jersey. There needs to be a delay before putting the call through. If you set that short, e.g. 2 seconds, then if the caller pauses after 201 to look up the rest of the number, the call will fail. If it’s long, e.g. 5 seconds or more, it’s an annoying delay on all internal calls.

If your desired numbering plan conflicts with one or more feature codes, IMO it’s better to change the feature codes.

Thanks for the input Stewart. I am new to this voip system, and it is a new install, so I can set my extensions to whatever numbers I desired. I dont know what feature code numbers are in use right now, as I am still new, so I am still making mistakes. I guess your right about the extensions… right now I have to hit the send button before it connects, no matter what number I dial. I need to lookup the config options to change it how you described(I am use to voip phones working like that by default). If you were starting a new system, how would you label your office phones? This one YT guy starts his at 200. Once I get a system that works, I usually don’t change it, unless the customer requires it.

Also, I found the answer to my problem. When I went to Connectivity->Outbound Routes->SIPStation-out and clicked on the advanced setting’s tab I noticed that all my new extensions where automatically put under the blocked extensions. For some reason 101 was not. So I unblocked them, and everything works great! Not sure why that happened.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.