Phone no longer registering

We are implementing a proof of function for freepbx and were going to set up my desk phone to run through it and a twillio trial. The main IT guys has used freepbx but a long time ago. Hes been messing with the system to try and get twillio to work through the firewall. Initially it worked outgoing only. He changed the server to be located on the DMZ (different ip) and the phone worked fine just changing the ip (across networks). However he also changed the ports back to install default (pjsip 5060 chan sip 5160) and now getting this error

[2019-07-16 15:37:31] NOTICE[14130] res_pjsip/pjsip_distributor.c: Request ‘REGISTER’ from ‘<sip:[email protected]>’ failed for ‘’ (callid: [email protected]) - Failed to authenticate

using chansip port 5160

both networks listed in local networks

changed chan sip setting for NAT to no

tried default password and simple password and voicemail pw, copy and paste from system into phone config

system has been rebooted

virtual machine loaded with asterisk/freepbx

Current PBX Version: 15.0.16

Current System Version: 12.7.6-1904-1.sng7

phone grandstream gxp1625

next step is to reinstall and start with trunk settings.

When this happens, there are usually one of two culprits:

  1. You are setting the phone up in “Chan-SIP” and connecting via the PJ-SIP port (note that the error message is from PJ-SIP).
  2. You credentials are hosed. From the error message, it looks like the credentials you are using are wrapped in XML. That could be an artifact of your cut-and-paste, but the < at the beginning makes me suspicious.

the other admin changed the pjsip to match (chan sip) and i think the system is confused. I changed chan sip port to 5062, restarted asterisk and after typing in a new simple password (no cut and paste)

NOTICE[707] res_pjsip/pjsip_distributor.c: Request ‘REGISTER’ from ‘<sip:[email protected]>’ failed for ‘’ (callid: [email protected]) - Failed to authenticate

originally i configured the sip ports, changing the defaults to be 5060 chan sip and 5160 pjsip. In his recent attempt to get our inbound calls working thru the firewall he (other admin) changed pjsip to 5060 with ought changing chan sip first. The system marked chan sip as 5062 however i have changed it, with restarts. However i just made a pjsip extension, gave it the chan sip port 5062 and the phone registered.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.