Phone Making Outgoing Call Display's Weird Characters

Just this past week I have a customer that when they make outgoing calls the phone displays weird characters. Im not 100% sure but they say this normally displayed the CID of the number they were calling. I can’t seem to figure out what is causing that.

So i tried it on a SNOM 725 phone and it puts a little “Square” box in from of the dialed number on the snom phone. It should say CID:########## and the number dialed.

Here is what i see when i do a trace. I blanked out the number dialed in Red. You can see a weird character being passed.

That is the value inserted into the CEL table for cid_num and cid_ana, they are set up earlier in your call.

When i go into the logging on the phone here is the PAI that it sends over. That is what i see above.

P-Asserted-Identity: “€1##########” sip:%FFFFFF801##########@192.168.0.3

Where do you think it gets those random characters from? All of a sudden last week it started doing that. Phone system was working great for 5 years :slightly_smiling:

sip set debug on/ip to see what’s coming from the vendor and of course what you are sending.

This is what im seeing from the sip trace. Its coming on the P-Asserted-Identity header. Does that tell us much?

<------------>

e[Klocalhost*CLI>
e[0K > 0x7f2b6cf61b10 – Probation passed - setting RTP source address to 172.16.2.37:65404

e[Klocalhost*CLI>
e[0K[2016-02-23 23:30:56] e[1;33mNOTICEe[0m[2628]: e[1;37mchan_sip.ce[0m:e[1;37m16436e[0m e[1;37mcheck_authe[0m: Correct auth, but based on stale nonce received from ‘“Jon” sip:[email protected]:5060;tag=aeb6544d9b’

e[Klocalhost*CLI>
e[0K[2016-02-23 23:30:57] e[1;33mNOTICEe[0m[2628]: e[1;37mchan_sip.ce[0m:e[1;37m16436e[0m e[1;37mcheck_authe[0m: Correct auth, but based on stale nonce received from ‘“Scott” sip:[email protected]:5060;tag=e0775d0bda’

e[Klocalhost*CLI>
e[0K[2016-02-23 23:30:59] e[1;33mNOTICEe[0m[2628]: e[1;37mchan_sip.ce[0m:e[1;37m16436e[0m e[1;37mcheck_authe[0m: Correct auth, but based on stale nonce received from ‘“Jay” sip:[email protected]:5060;tag=130a4479b0’

e[Klocalhost*CLI>
e[0K – DAHDI/i1/1##########-25 answered SIP/223-0000002d

e[Klocalhost*CLI>
e[0K – Executing [[email protected]:1] e[1;36mSete[0m(“e[1;35mDAHDI/i1/1##########-25e[0m”, “e[1;35mCHANNEL(musicclass)=EasyOnHolde[0m”) in new stack

e[Klocalhost*CLI>
e[0KAudio is at 19650

e[Klocalhost*CLI>
e[0KAdding codec 100003 (ulaw) to SDP

e[Klocalhost*CLI>
e[0KAdding codec 100004 (alaw) to SDP
Adding codec 100002 (gsm) to SDP

e[Klocalhost*CLI>
e[0KAdding codec 100011 (g726) to SDP
Adding non-codec 0x1 (telephone-event) to SDP

e[Klocalhost*CLI>
e[0K
<— Reliably Transmitting (NAT) to 172.16.2.37:54056 —>
SIP/2.0 200 OK

Via: SIP/2.0/UDP 172.16.2.37:54056;branch=z9hG4bK-h6hsj9xh6y69;received=172.16.2.37;rport=54056

From: “Joe” sip:[email protected];tag=dp9b89ehs4

To: sip:#######@192.168.0.3;user=phone;tag=as60f480c2

Call-ID: F931CD5645610A14A6681AC1BE50F230-k3dht1qrtrky

CSeq: 2 INVITE

Server: FPBX-12.0.76.2(11.15.0)

Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE

Supported: replaces, timer

Session-Expires: 1800;refresher=uas

Contact: sip:#######@192.168.0.3:5060

P-Asserted-Identity: “€1##########” sip:%FFFFFF801##########@192.168.0.3

Content-Type: application/sdp

Require: timer

Content-Length: 310

again without the ansii escape shit please

I’ll work on that. Do you suspect it’s something on the telco side or freepbx side? It’s once the call is answered that we see this weird characters. I just don’t want to beat on freepbx if it’s probably an ATT issue. Only common thing I can see that happened was last week we had a power outage and I’m guessing everything was hard shutdown. Majority of the issues we have are normally telco related. Just not sure on this one.

Does P-asserted-identity have anything to do with the telco on outbound calls?

I suspect you have a munged Asterisk.

I agree with @dicko. I bet your database has a crashed table that you need to repair.

Easy fix to do a database check/repair on the whole database?

I don’t think there’s a single command. The way I’ve always done it is log into the MySQL interface program and use “Use Asterisk” and “Show tables”. Copy the table names and paste them into a script and add "repair table " to the front of each line.

Call the script “repair.sql” and you can use “mysql -u root asterisk < repair.sql”

The database name may need some tweaking. The problem could also be in one of the FreePBX tables (look for a database called FreePBX maybe) and repair those.

So, no. The first time it’s not easy, but after you have the script updated, you can add it to your daily cron job and run in prophylactically.

You asked:-

did you try

?

For anyone running into the issue. Wasn’t a freebpx issue. Did a reboot on our ATT router which the PRI comes off of and that seemed to resolve the problem.