Phone lights up every once in a while

Ok… Here is another question from the someone who is not sure what he’s doing (or not doing) :slight_smile:

I got Asterisk 1.2.7.1 and FreePBX 2.1.0 installed. I did not install SPANDSP as I do not want Asterisk to do the faxing.

Now… Most of the things are working fine, but some are not or weird things happening:

  1. I nailed down that every time I see manager.c: Manager received command ‘Command’ in /etc/Log/Asterisk/full my phone would show “Incoming call” on the LCD screen for a couple of seconds. However, there is really no incoming calls. Phone is a standard phone connected to Sipura 2002.

  2. Conference - does not work. If I create a conference and dial in that line (from internal phone) - regardless if there is an admin pin or not - it would not let me start the conference.

  3. Extension that is configured with option for recording “On Demand” - when I hit *1 - nothing happens.

  4. System Recordings - entered the extension from which I would call to make a recording - dialed *77 - nothing happens - just a dial tone in respond.

Could someone point me into the right direction? What am I looking for? The most annoying is the problem #1. The rest - well… I can (or at least this what I think) fix it manually. I renamed extensions_custom.conf.sample into extensions_custom.conf and I can make system recordings by dialing 5678… But it would be nice to get *77 working… as well as *1. By the way, voicemail (*97) works fine. Weird.

Thank you guys in advance.
B.P.

  1. extension that i

Have you checked to see if the *1 or *77 features in your Sipura phone may be intercepting these commands befor they get to Asterisk. I turned off all * commands in my phones when I had similar problems, and they went away.

Cool! I disabled all “Vertical Service Activation Codes” in sipura “Regional” Menu (advanced admin login). but I left “Outbound Call Codec Selection Codes” along (*017110 etc.). Did you disable those on yours as well or not?

I can now use *77 and *99… *1 still does seems to be working. and the phone still lights up every once in a while. After more careful review, it looks like it lights up when SIP registration occures.

Thanks,
BP

[quote=“bobp”]After more careful review, it looks like it lights up when SIP registration occures.[/quote]Those false incoming calls do arrive about my Sipura re-registration time. So the re-registration is certainly involved here. While disabling MWI may help, I prefer to have MWI working. Is there any other way around?