Phone conversation intereference

A user reports that the phone is ‘ringing’ while they are on the line with someone, and that it’s doing so incredibly loud and that the other end can actually hear it. This does not seem like it’s simply a second incoming call on the other line.

We have been having some bandwidth issues that are trying to get resolved - would this congestion potentially cause some of these issues?

No, bandwidth congestion would not cause that issue. Sounds like analog lines with crosstalk to me…

How do you mean? Everything runs over cat5 on a cisco 48 port PoE switch, and the system reports 100mb full duplex connection. I see no dropped packets, faults, re-transmits or anything on the NIC it runs over either.

There’s also been mention of distortion for inter-office calls, where it doesn’t even touch the internet uplink. What would be causing the issues?

It’s a dual core opteron system with 2gb memory, and cpu/memory/disk stats show very little stress or utilization for the 18 or so handsets and 6 outbound channels that we have.

I’m at a bit of a loss to narrow down these problems further, any advice on troubleshooting is welcome.

If you have that fancy managed switch do you have the phones in their own VLAN?

What kind of phones?

Aastra 9143i - xml scripts are installed like you had me do way back in the beginning, no other changes have been made since then other than more and more activity/use of the system over time. It’s been pretty solid up until the past couple weeks.

You mentioned your traffic went up. Must be having some type of broadcast storm or some other UDP event.

Aastra’s are very intolerant of tons of Broadcast traffic. Even a VLAN won’t always help.

I think that the “baby” Cisco switches (the ones that don’t run IOS) still have some type of Broadcast message rate limiting.

Hmm… I’ll have to see if I can sniff it out. Any ideas on what might be a good place to start looking? Most of the traffic that I know of at the office is pretty direct client/server type stuff, I’m not sure what would be causing broad spectrum UDP traffic. Up until now everything (phones included) has just been in a flat 192.168.0.x layout, I could definitely put the phones on a different network if you feel that would help cut out unnecessary chatter that they don’t need to be bothered with getting showered with.

A good place to start is


if that doesn’t show the problem immediately then

man tcpdump

which can be used to filter out (or in) each and every bit of network traffic you have using any protocol on any one of your network interfaces you have on your network for closer inspection.

The 9143i being mentioned as UDP sensitive and the tcpdump sniffing recommendation has me curious about something:

Our office uses folder redirection as well as a number of central domain controller network shares and these get used heavily during the day. This is certain to generate a lot of traffic during the day, of which I’m sure a large portion is UDP. Currently since the phones are part of the same 192.168.0 block as the rest of the network they would be subject to seeing all of this fly by.

That being said, since the phones are used as pass-through devices for the workstations they belong to (Computer -> phone -> wall -> PoE switch) would putting only the phones in a 10.X network and setting up an additional interface on the asterisk server to service that segment get around the issue? Should I dig deeper into the ‘Voice VLAN’ section of the switch’s configuration?

We have about 25 PC’s in the office, and about 20’ish phones.

Even putting the phones in a VLAN will not solve your problem. However the correct procedure for VLAN’s

1 - Enable VLAN trunking on each switchport
2 - Set data VLAN as untagged
3 - Set voice VLAN as tagged
4 - Configure voice VLAN on phone

This won’t completely solve your issue because the problem is packet congestion on the interface. I am not that familiar with the Cisco small biz (ne linksys stuff) however I am sure it has some type of UDP multicast/broadcast rate or flow control. You need to enable that on the phone ports.