Phone Connections

I am running lastest free version of Asterisk with FreePBX. I am connecting a Grandstream Budgetone 100 and have it configured as ext 102. I have everything setup in FreePBX as it being ext 102. When I dial the extension from an outside phone line it immediately rolls to my voicemail for ext 102 and won’t ring the Budgetone.
If I push the message button on the Grandstream phone I get an message saying the person on ext 102 is on the phone and then rolls to let me leave a message on the internal phone. When I try to dial out on it I get a dial tone and can dial out on the phone and it will ring an outside phone with no problem however I can’t talk or hear anything on the phone. I’m sitting here drinking a beer and going in circles. Can anyone tell me where I am going wrong? Any help is appreciated.

Also wanted to add that I am running the phone though my belkin router to my box running asterisk. The ip on the phone is and the box is Do I need to Nat the router somehow?


Are you sure you mean ‘router’ and not switch?
If router then you will need correct subnet set both on phone, router and server.
If switch then the addresses are ok.
If router why is the phone not on the same network as the server?
My advice - provide direct path between phone and server.

yorweb, your first mistake was not offering the rest of us a beer and a comfortable chair to come join you…

Just kidding. When a phone is called and it rolls over to the voicemail immediately on a new setup it is most likely that your phone is not properly configured and registered with your system (in your case it might be partially configured as it can dial out). Next is that DND is enabled.

As for “When I try to dial out on it I get a dial tone and can dial out on the phone and it will ring an outside phone with no problem however I can’t talk or hear anything on the phone.” This is the classic firewall NAT issue.

For the NAT issue I’d use google as there are thousands of pages already written and available to help people with this. One I can point you to is: Yes you might not be using that distro, but you know what? This a VERY common mistake and since they took the time to write it all up I’ll just point you there.

I will research nat. I thought I had it configured but one beer lead to another and by the time I finished I wasn’t even sure there was a key pad on the phone. I’m going to start fresh tonight… and tadpole, thanks for the information. It is a router and I may end up just putting a second ethernet connection to the box. I was trying to set it up on my network so my brother in Orlando could access it here in Tennessee and just figured it wouldn’t be that difficult to run it through my network router…I appreciate all the help…I’d give ya’ll a beer if you were here…

Thought maybe it was the network setup in asterisk causing problem. If I set it in dynamic mode it works fine with however phones still not working correctly and I’m thinking this may be part of the problem. So I try setting static ip information in asterisk and absolutely could not get it right. I know internal ip is and the subnet is but the last two couldnt figure out if I needed the router ip, or the dsl static ip or att dns server information. Everytime I would change it then try calling my phone number from external number I would get the callcentric guy telling me the number was not available. As soon as I put the dynamic ip back in atleast I could reach the voicemail on the ip phone which is ip or ext 102. Still no phone ring or voice in or out. I change the nat on router. I figure if I keep dwindling down what it ain’t, eventually I might hit on it…anyway…time for a glass (or bottle) of wine and I’m calling it a night…

For external calls to work through NAT, you need:
Port forwarding set on the router to forward the SIP & RTP ports to the IP of the Asterisk machine (around 5060 & 10001-20000, make sure rtp.conf has the same range)
your /etc/asterisk/sip_nat.conf set up with your ‘real’ external IP in externip so outgoing packets have the correct address for the replies.

externip =
localnet =

Your basic internal IP settings look OK, assuming both phone and asterisk machine are on ‘user’ ports of the router or modem.

Guessing: If it’s a cable router, there is one port for the cable side and four? ports at the user side. If it only has one cable + one user port, you need to add a switch to give you multiple ports on the ‘user’ side.

If it’s a combined ADSL box with a built-in ADSL modem with eithernet and has more than one ethernet port, it has a switch built in. If it only has a single ethernet port then again you need to add a switch.

When using a external SIP provider you also need to enable allow “Allow Anonymous Inbound SIP Calls?” under general settings. otherwise the system will reject those connections.

I tried both your suggestions and still can’t get it to configure. I am making progress though…Maybe you can add more direction to it…I tried putting in my callcentric information directly into the phone that is still connected to the router and made a call and it worked ok. I then reconfigured the phone with information from my box etc and I now have it to the point that if I call my grandstream phone that goes through the router to the pbx to the phone it will ring. When I pick up the phone it stops ringing like it is connected but still no voice in or out. The funny thing is my cell phone that I am placing the call from continues to ring like it has not connected and then my voice mail for my extension on the pbx answers.
If I place an outgoing call from the Grandstream it goes though ok to my cellphone but still no sound.