Phone Apps Login problems

When trying to use the login/logout feature on our phones, logout works fine. However, trying to login produces an error “User was not specified”. It appears that the phone is sending a request with user id set to 0000, which would be correct since there is no user logged into the phone currently.
Tried opening a ticket, since PhoneApps would be a commercial module, but cannot since I am using it only with Sangoma phones, therefore I did not have to buy it with a support contract.
Any ideas on how to make this work?

We released the following modules to deal with this issue:
Restapps v13.0.93.3
Restapps v14.0.22.3
Restapps v15.0.19.3

Please make sure you’re running one of those versions. Duplicate Topic: Phone unable to login, must reset user from '0000' to '1000' via phones webserver

@mbrooks I’m getting the same error “User was not specified” when pressing Login Int button. I don’t see a ‘Restapps’ entry in Module Updates. Are either of these what you mean?

  • Phone Apps

Neither of them show available updates available on my system.

I’ve tried factory resetting the phone and rebooting the PBXact system. My extension range is 4300-4399. The phones does receive auto provision settings and the restapps daemon is running according to the dashboard.

The version you want is still in edge, try running:

fwconsole ma upgrade restapps --edge

Thanks Lorne, it says I have the latest version:

[root@uc-######## ~]# fwconsole ma upgrade restapps --edge
Edge repository temporarily enabled
No repos specified, using: [standard,commercial] from last GUI settings

restapps is the same as the online version, unable to upgrade
Updating Hooks...Done
Resetting temporarily repository state

The “User was not specified” error message still appears when I press “Login Int”

How about:

fwconsole ma downloadinstall restapps --tag
1 Like

Thanks @lgaetz! That’s done it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.