FreePBX | Register | Issues | Wiki | Portal | Support

Phone Apps Hang


(Joe Pruett) #1

I have been working on a new sangoma based freepbx setup and the phone apps regularly get stuck (display won’t change when trying to navigate the menus or invoke actions). I have reported this to sangoma (back in july) but haven’t seen any further progress on it. I have updated to the latest firmware with no change.

After a reboot of the phone, things will work for about a day and then start acting up again. I mainly will be using the queue app to login/out. I can see that the led will change when I pause/unpause, but the display stays static with whatever state things were in when i entered the menu. Exit works, and if I go back in, then the display shows the correct state. I also programmed a button to be the generic apps button, and I’ll get the first screen that lists the apps, but selecting one doesn’t change the display.

I find it hard to believe that I am the only one seeing this behavior. Has anyone else run into this?


(Jessy5765) #2

I have worked with the Sangoma phones now for almost a year and the only one I ever seem to have issues with is the Voicemail app acting funny sometimes. All other apps work very well. I never experience any “freezing” of apps. I do know what if your in a parking lot or something the screen never changes.

One thing to understand is these are not “LIVE” apps. These are apps that poll an database using XML so whatever was in those files at the time that the app polled the database was what gets returned to the phone. Some of the apps have a refresh button for that reason.


(Joe Pruett) #3

i’ll give a more concrete example. i have an s500 phone.

line key 4 is set to xml-api rest-apps

so when i hit that key i get a menu of all the apps. conference is the first one. if i hit that, i should be told there are no conferences configured, and for the first day or so, i get that. but as of now when i hit that, it pops up the loading screen for a second, and then still shows the list of apps. hitting arrow keys does nothing. hitting the exit button does go back to the main display.

from doing a tcpdump during the transaction, i see the pbx sending back the xml saying there are no conferences authorized for my extension, but the phone doesn’t display that.


(Nick Casagrande) #4

open a ticket with sangoma, hardware support is free. i dumped my fpbx project b/c of the wackyness of the sangoma phones and some weird bugs in pbx. i cant jeopardize our business


(Jessy5765) #5

Okay. I have never used the Rest-apps app itself. I just assign the app to the line. Too many clicks otherwise. haha.

But yes to authorize conferences (its one of the few things you have to do) you have to do into User Management,Groups, All Users and go to Conferences then select which on you want them to have.


(Jessy5765) #6

Tens of thousands of business run on FreePBX… Saying the sangoma phones are wacky and bugs in pbx means nothing. I have learned more often than not… its me and my configuration of the PBX not the software itself. Only 2 times have i seen an actual bug and one was with Yealink not the PBX out of 16 deployments i have done.


(Itzik) #7

Interesting what you are saying. We have around 30 FreePBX servers up and running between our clients.
I can say that the community is very helpful plus you have their devs checking in here and assisting with any real issues.

Additionally, if you have some issues which you can’t figure on your own, you can always use paid support - which iv’e used already few times, and they are very responsive. (At least more responsive than other companies we bought PBX Servers from…)


(Joe Pruett) #8

i have contacted sangoma and they were able to reproduce it, but it has gone into some internal dev team and never surfaced again. if it was failing once a week or month i could probably survive, but this seems to be daily. it just seems like such an integral part of what the phone is supposed to do, that i can’t understand how i would be the only one seeing it. given that i see the pbx sending back what looks like the right xml, but it never ends up on the screen, it sure seems broken somewhere.

my example of using the rest-apps is just an example. all xml apps are broken. queues, vm, etc.


(Nick Casagrande) #9

i have actual ticket #'s confirming my issues, but whatever, it doesn’t really matter at that point. Not being able to use UCP from EPM is another bug since august with no work done on it either. the certificate manager not working unless you loaded the edge patch was another. listen, it’s free, i get it, however finding an issue with no resolution or when it will be fixed just isnt something i can run my business on. i believe if i used yealink it would have been better, actually my voip consultant told me to from the start and he’s been doing fpbx for years and years now, but i wanted sangoma as i figured it would be tighter integration and such.


(Joey Khan) #10

@jpruett did you ever find a solution for this? I am experiencing the same behavior in a commercial production environment, on PBXact. For some reason I feel like it’s switch-related, but maybe not.


(Joe Pruett) #11

no, i still have the issue. i keep hoping an update will come along, but nothing so far. if you’re paying for both phones and the pbx, maybe you’ll get more response from sangoma,


(Robert) #12

Hello all,

I have the same problem with the pbxact. When i reboot the phone every app is working good but after 24 hours the apps hang.

Is there a known solution for this? I have 37 phones with that problem.


(Joe Pruett) #13

nothing here yet. please push on sangoma with whatever method you have to try and get them to address this. i am looking to buy 10-15 phones, but this issue is holding me back.


(Robert) #14

Is there any debugging howto/wiki that will get me an error so i can investigate. Problem is that i dont know where to look at.


(Joe Pruett) #15

i have watched network traffic and the server seems to be sending the correct xml, but the phone just stops processing it correctly. i got someone at sangoma to confirm they recreated it, and that it had been handed off to engineering, but it was being tracked as an internal issue, so there is no visibility for progress. that was july 2017.


(Robert) #16

I just put a official ticket in the support portal for this.

I had this from the start of my pbxact 300 installation. If i have some new information i will post it here.

Its not a very big deal but its pretty annoying.


(Andrew Brysiuk) #17

I’m seeing the same issue. Would you guys be able to provide ticket numbers we can refer to in creating our own tickets? Or is there a bug tracker issue created yet?


(Robert) #18

Sorry for late reaction.

I submitted a official ticket on the support portal from sangoma. I got contact with them and they say they know of the problem but it happens to a couple of known costumers.

Currently i am testing it with them. The issiue seems that by default the phone provisions itself to the endpoint manager every 24h and then the apps hang.

I set the provision time to about 8 weeks to test it if by that time the apps dont hang.

If you really need to reprovision your phone just reboot it or force provision by the endpoint manager.


(Joe Pruett) #19

yep, reprovisioning does seem to break things. i just tried using 0 as the setting, but that gets turned into 10 minutes. after i saw it check, sure enough the apps weren’t working. i have now set it to 90 days and i’ll see how that goes.


(Joe Pruett) #20

even provisioning from the endpoint manager breaks things. i wonder if using tftp for provisioning instead of http might help?

but this is good news that at least they have an idea of where the problem is. it has been in multiple firmware versions, so hopefully it isn’t too hard to fix.

well, just checked tftp and that didn’t help. also updated to 2.0.4.43 firmware which doesn’t seem to impact it either.