Phone Apps/EndPoint Manager Version Issue


(Mo The Mighty) #1

Hello, on a system with FreePBX 12.7.6-2002-2 and Asterisk 13.29.2 I received the error that the “Phone Apps” module needed to be updated for security purposes, but when I tried to do so, it said I did not have a qualifying version of “EndPoint Manager” and that it needed to be higher than version 14.0.41. So, when checking for updates for “EndPoint Manager” there were none, so I put it into “Edge Mode” and was able to update “EndPoint Manager” to version 14.0.5.1, but now “Phone Apps” is “Not Installed (Locally Available: 14.0.22.2)” and it states “Missing Requirements: ‘EndPoint Manager’ module version 14.0.41 or higher is required, you have 14.0.5.1.”

Any help is very much appreciated.


(Lorne Gaetz) #2

Sounds like your EPM module maintenance period has expired:
https://wiki.freepbx.org/display/FPAS/How+to+Renew+FreePBX+Commercial+Modules+Maintenance


(Mo The Mighty) #3

So that still applies even though I am using all Sangoma phones?


(Lorne Gaetz) #4

If you have a paid license, yes. Otherwise no.


(Mo The Mighty) #5

Lorne, I do not have a paid license. We have been using all EndPoint Manager and Phone Apps with our Sangoma S500s. However, now because of this issue, Phone Apps are not working. Do I need to purchase a license to get it to work again, or, since we have all Sangoma phones, is this something I can create a ticket for?


(Lorne Gaetz) #6

No.

Yes.