Phone Apps Daemon keeps crashing

Phone Apps Daemon crashes about once a day, same with XMPP Presence Daemon.

In restapps logs, there isn’t much, only old stuff:

[19-Jul-2016 18:14:31 America/New_York] PHP Warning: Invalid argument supplied for foreach() in /drbd/httpd/www/html/admin/modules/endpoint/functions.inc/functions_general.php on line 110
[11-Nov-2016 12:35:45 America/New_York] PHP Warning: fclose() expects parameter 1 to be resource, boolean given in /drbd/httpd/www/html/admin/libraries/php-asmanager.php on line 485

Anything to look for in var/log/asterisk/full?

This means you were probably not connected to Asterisk… Is Asterisk running? Maybe asterisk crashed?

This means something that should have been an array wasn’t. Maybe something pulled from asterisk manager… I would suggest filing a commercial module ticket since this is restapps/endpoint. Also If you are running the latest I believe the new daemon system has better logging. They can take a look

The logs are now in: restapps_out.log, restapps_err.log

Are those in var/log/asterisk?
I only have restapps.log in there.
I am on phone apps 13.0.84.8.

Yes. RestApps is at 13.0.85

Is 13.0.85 edge?
I recently purchased the yearly maintenance, but it’s not giving me the option to upgrade to 13.0.85.

Latest Edge for PhoneApps is 13.0.86.2

13.0.86.2: one too many calls
13.0.86.1: Stop old process
13.0.86: Better logging and error handling
13.0.85: PHP 5.6: Updates

Trying to upgrade phoneapps without success, - Retrieved Module XML Was Empty:

[[email protected] ~]# fwconsole ma upgrade --edge phoneapps
Edge repository temporarily enabled
No repos specified, using: [standard,extended,unsupported,commercial] from last GUI settings

Starting phoneapps download…
The following error(s) occured:

  • Retrieved Module XML Was Empty

This entire time we’ve been saying restapps. Try again with restapps. Phoneapps is not a module.

Ah ok. Got confused because in module admin it’s called phone apps.

I restarted restapps and will post logs if it crashes again.

1 Like

Seeing the same issue here for months. Even on fresh installations. Will post log files soon too if I can track something down.

Same issue here. Tried a lot, so far nothing helped.

A new version was published a few hrs ago.

Great. Downloaded and installed. WIll give feedback (usually took a day or two to crash)

Looks okay since the update. Was running whenever I checked. Thank you so much!

1 Like

I created a cron to fwconsole restart restapps at 6 am daily because every monday morning the daemon would be down. Is it truly fixed and in what version of restapps?

Phone Apps 13.0.86.3 will be upgraded to online version 13.0.86.5

1 Like