Permission denied to recordings: /admin/modules/recordings/popup.php

Hello There
I cannot listen to recordings via the web gui. It is the 403 - forbidden - message.

Permissions in relevant folders are 770 or 775.

It is the same for the included recordings or for custom recordings.


I’ve the same problem, there is a solution ?

no, I haven’t found anything yet

Michael Daly

My freepbx gui is password protected, and accessible via a virtualhost httpd.conf arrangement.

I think the problem was related to the directory not having an index file, i.e. as in the admin/modules/recordings/ directory. So I added the following 2 lines to the relevant section within httpd.conf:
Options +Indexes
AllowOverride None

(you would think AllowOverride All or AllowOverride Options would make more sense, but these resulted in a 500, rather than a 403, error)

So the complete definition in my case is (for virtualhost port 400, user 'compused’
I had to delete the tag ends as they were not appearing in the post):

VirtualHost default:400
DocumentRoot /var/www/html
Directory "/var/www/html"
Options +Indexes
AllowOverride None
#added above 2 lines so could listen to system recordings
AuthType Basic
AuthName "Restricted Area"
AuthUserFile /usr/path/to/the/file/wwwpasswd
Require user compused
#Directory “/var/www/html/admin/modules/recordings”
#allow from all
ScriptAlias /cgi-bin/ “/var/www/cgi-bin/”

(another way to do this, which is commented out above, and again no tags, was:
Directory "/var/www/html/admin/modules/recordings"
allow from all
but I didn’t feel as comfortable with that)

[A reference is:

How do I fix a 403 error?
A: The purpose of the 403, forbidden, error is to control access to Web resources. To overcome an unwanted 403 error you must reverse this situation. If you have problems accessing a particular file or directory, ensure that the Web server has permission to read those files. Usually, the Web server will operate under a special user account, so make sure that user has read permission.

The second most likely case is that you have requested a virtual directory URL that has no index document and is not configured to list the contents of the directory. In this case, either create an index for that directory or change the settings to permit directory listings. For Apache, use the Options +Indexes directive in the .htaccess file for the directory. This in turn relies upon overrides being enabled in the main http.conf configuration, see Custom error 403, access forbidden. ]

Michael Daly