PBxact won't update, appears to be ipv6 issue

Pbxact won’t update, it appears to be trying to connect to ipv6 but I don’t know why. How do I disable it?

yum update -y
Loaded plugins: fastestmirror, versionlock
Determining fastest mirrors
Could not retrieve mirrorlist http://mirrorlist.sangoma.net/?release=7-8.2003.5.el7.sangoma&arch=x86_64&repo=os&dist=$dist&staging=$staging error was
14: curl#7 - “Failed to connect to 2606:4700:10::6816:2096: Network is unreachable”

One of the configured repositories failed (Unknown),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=<repoid> ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable <repoid>
    or
        subscription-manager repos --disable=<repoid>

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice
    compromise:

        yum-config-manager --save --setopt=<repoid>.skip_if_unavailable=true

Cannot find a valid baseurl for repo: sng-base/7-8.2003.5.el7.sangoma/x86_64

ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 00:90:27:ed:b8:48 brd ff:ff:ff:ff:ff:ff
inet 192.168.11.2/24 brd 192.168.11.255 scope global eth0
valid_lft forever preferred_lft forever
inet6 fe80::290:27ff:feed:b848/64 scope link
valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:90:27:ed:b8:49 brd ff:ff:ff:ff:ff:ff
4: eth2: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:90:27:ed:b8:4a brd ff:ff:ff:ff:ff:ff
5: eth3: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
link/ether 00:90:27:ed:b8:4b brd ff:ff:ff:ff:ff:ff

And

ping -6 mirrorlist.sangoma.net
connect: Network is unreachable

pinging google.com works fine.

You don’t have an IPv6 address configured anywhere (the link local address doesn’t count). So it is already effectively disabled.

Do you have a working default route for IPv4? (netstat -rn)

Whether you use v4 or v6 the cloudflare proxy should work for you. (Try these commands from your PBXact)

$ curl -6  "http://mirrorlist.sangoma.net/?release=7-8.2003.5.el7.sangoma&arch=x86_64&repo=os"
http://sng7.com/os/7.8/os/x86_64/
$ curl -4  "http://mirrorlist.sangoma.net/?release=7-8.2003.5.el7.sangoma&arch=x86_64&repo=os"
http://sng7.com/os/7.8/os/x86_64/
$ 

netstat -rn
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
0.0.0.0 192.168.11.1 0.0.0.0 UG 0 0 0 eth0
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth0
192.168.11.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0

curl -6 “http://mirrorlist.sangoma.net/?release=7-8.2003.5.el7.sangoma&arch=x86_64&repo=os
curl: (7) Failed to connect to 2606:4700:10::6816:2096: Network is unreachable

Got it figured out there was a firewall policy blocking internet access and there was no exception for the pbx. Thanks for your help!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.