PBXact Detects DTMF Sometimes!

siptrunk
Tags: #<Tag:0x00007f7026208170>

(Brian) #1

Hello,

So i have been doing some test calls in my new installation and for some reason DTMF is not detected by my PBXact in most of the calls but the strange thing is that it does detects DTMF in some random calls. When i reach my IVR and i dial my Option is does work in very few occasions.

On this log you can see that DTMF is being detected:

But in most of the calls the logs doesn’t show anything for DTMF.

Any idea whats happening here?

Thanks you All!


(Dave Burgess) #2

I’d submit this as a commercial ticket too (since you’re on PBXact, the commercial version of FreePBX). They may have some insight.

If I was a guessing man (and we all know I am), it’s probably going to boil down to something like DTMF duration on one of the intervening systems.


(Brian) #3

Yes i did opened a ticket. Lets see what they say. Thanks!


(Brian) #4

Hello,

Seems like i found the issue. So after inspecting the WS captures and i can see that my provider in some calls sends a Payload with RTPType-101, g711u and when i get this Payload FreePBX doesn’t detect DTMF. But when they send Payload with just g711u it does detect DTMF. This explains why is intermittent issue payloads are different on each call. So now this is some setting i need to adjust on my end or my provider needs to adjust their settings?

Thanks!


#5

Assuming a pjsip trunk, try setting DTMF Mode to RFC4733. With luck, provider will send payload 101 on all calls and Asterisk will recognize it. If this stops DTMF from working altogether, try setting DTMF Mode to Inband, which should tell provider not to send 101. If this also doesn’t work, we’ll need more details logs to see what is going wrong.


(Brian) #6

Yes im using PJSIP trunk. My PBX is behind an SBC the media profile on the SBC is set to RFC 2833. I did tried to change my SBC and Trunk to Inband but same result. Also i set my trunk to RFC4733 and nothing. See the example below of the flow senescence when it works and when it doesn’t work and you can see how when payload comes with RTPType-101 the SBC doesn’t relay DTMF to the PBX.

DTMF:

NO DTMF Relay: