Pbx upgrader problem

Hi,
In module admin i can see the Pbx Upgrder Module.
Its not installed.When clicking on it ,it shows only

PBX Upgrader Stable Sangoma Technologies Corporation Commercial Not Installed (Available online: 12.0.4)
Attention
Info
Previous

You will be updated to the next version. You should make sure you have a full backup of your current system. Version 13+ requires Asterisk 11 or later. Once you upgrade, you can not downgrade. It may be possible to restore a backup though restoring a system that has been upgraded can run into some anomalies later on though will usually get you back to where you were.

nothing else .There is no download option.
Thanks for any help

You need to click “info”

WOW.
That was VERY fast.
Thanks a lot