"PBX Status" blank

I apologize in advance if this is the wrong forum to post this issue, but I haven’t been having much luck over at the Trixbox forum.

I also do not know if this falls under the FreePBX functionality but here goes…

In Trixbox, under the “PBX” menu item there is a “PBX Status” item. It’s suppose to show a report related to the setup of the box as far as extensions, registration, trunks etc. Thing is when I click on it the browser displays the page, the cpu pegs but no real data is forthcoming. After a while it times out and the cpu returns to a normal amount of usage. According to the httpd error log it appears to be related to an inability to log in. I’ve checked password settings everywhere I can find them to no avail. Listed below is the post on the Trix forum.


My PBX Status page does not show any info. When I access that page, after several minutes all I see is “PBX Status: trixbox1:localhost” in a banner at the top, and “Version” below it. I’ve tried chasing back through the PHP code, and found the astinfo function, but my chops in PHP are poor and I wasn’t able to diagnose anything significant.

The asterisk/full log shows:
NOTICE[3327] manager.c: 127.0.0.1 failed to authenticate as 'admin’
VERBOSE[3327] logger.c: == Connect attempt from ‘127.0.0.1’ unable to authenticate

The HTTPD error_log shows the following when I try to access “PBX Status”
[error] [client 10.10.0.111] Sat, 13 Jun 2009 20:47:29 -0500 - Failed to login., referer: http://10.10.00.253/maint/index.php?freepbx

I’m not sure why these login errors are appearing, this used to work and (as far as I know) no passwords have been altered. I have checked this in amportal.conf and all is as it should be. I do remember a lot of pain when I originally changed the passwords, having to hunt down hard coded password instances, but I don’t remember where they were, and besides I haven’t changed any of them, and everything else is working fine.

Can anyone offer a clue?

Once again sorry if I’m barking up the wrong tree (or forum) here but I’m not sure where the delineation is between function as far as what’s FreePBX and what’s Trixbox…

Thanks in advance…

http://lists.digium.com/pipermail/asterisk-users/2007-March/181713.html

It worked for me, hope it does for you.

Brandon

Many thanks for taking the time to post this, it was the issue.