Pausing after sending out a 9 on an FXO (SPA3102)

I’ve set up a Cisco SPA3102 (one FXO/one FXS) to seize an analog PBX station line and dial a 9 and then the 1+NPA+NXX after a pause. Everything works except the PAUSE after the 9.

How the heck do I set that up?? (PIAF Purple

Thanks a bunch…

Norm Z

Can we assume your box it behind a PBX or Centrex system ?

You can do that either in either the ATA or Asterisk but the ATA’s dialstring and the FreePBX outbondroutes/trunk settings are concomitant on each other and you kinda have to “stretch” the SIP compliance to let Asterisk do it.

So it is probably best to let the 3102 do it as that is where you should directly control line impedance, “Regional” settings, battery voltage (pbx), flash timing (Centrex/PBX) etc. to concur with what it is looking at.

Just program the device such that the FXO/PSTN port is matched to your provider and the network interface to look like a e164 compliant SIP gateway to asterisk, (there are plenty of tutorials out there in Google land to do that, and the devices own manual also largely covers the howtos). The defaults for the FXS/phone port are by default usually just “good” if you take out all the “vertical” provision codes.

The 3102 is behind an older Avaya PBX/key system. I have the 3102 PSTN dialplan with an “8,1NxxNxxxxxx” but the PSTN port actually dials out a “9”. How can I insert the pause in the * trunk settings or outgoing route???

Thanks for the help!

Norm Z

Again, you should do that in the dialstring you set on the 3102 (the trunk to the 3102 from Asterisk should eat the initial 9 if your outbound route assumes such dialing patterns).

if you don’t change that and other values as I pointed you to (plus others) then you will almost certainly experience echo, hangups, and incomplete calls as you go forward. An Avaya FXS port looks nothing like a “standard” AT&T analog line which the 3102’s FXO port defaults are set to talk to, please don’t make the mistake of half-assing it now when you have the chance to do it properly.