Park not showing caller ID in history RPID?


(Sentinel) #1

I am using yealink phones. If I transfer a call when RPID is set to “Send Remote-Party-ID header” is set it works perfect. How ever when use park, it shows the park Slot number in the history. Any thoughts?


(Dave Burgess) #2

I know we’ve talked about this before, but it’s been a long time (a couple of years for sure) and I honestly do not remember if there was ever a resolution other than "it sucks to be you. :slight_smile: " Search the forum (top right magnifying glass) for “Caller-ID Park” and see if anything pops up that looks like a good match for you.

If you don’t find anything, post your “pedigree” (thanks @dicko) and a /var/log/asterisk/full example of a call where the CID comes up wrong.


(United States) #3

What type of Yealink phones are you using and what firmware version? We use the T48G model on firmware 35.8.0.50 and the T48S on firmware 66.84.0.10. Both show caller ID after you have picked up the call. Trust RPID is set to TRUE and Send RPID is set to Send Remote-Party-ID header for all extensions. I’d start by double checking each extension to ensure that all are set correctly.


(Sentinel) #4

Firmware is 36.83.0.50 which is current. I have those exact settings and it is not working. Maybe it’s a PBX setting?


(Sentinel) #5

12.7.6-1904-1.sng7

Full log with test park calling here:
Full Log Download


(United States) #6

Maybe it has to do with blind vs. attended transfer (see @plindheimer Passing Caller ID to Extensions upon transfer)? In the Yealink GUI you can check Features -> Transfer


(Sentinel) #7

capture

I’m not see anything there. Transfer also works. It’s park that does not


(Sentinel) #8

I resolved this by adding this to the basefile

features.pickup_caller_num_record.enable=1


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.