Park Courtesy tone won't go away!

System is a Freepbx distro version 6.12.65-31. All the modules are up to date. The customer is very irritated with the park courtesy tone. I said sure I can turn it off. Not so much.

Setting the Pickup courtesy tone to None does not work. The asterisk version is Do I need to upgrade to Asterisk 11? If so How is that accomplished?


grep courtesytone /etc/asterisk/features*


I found it… looks like we add that for asterisk versions below 12 if you are using Asterisk 13 it goes away.

You can try adding



I will try that. I actually tried courtesytone=no I will try adding ne :)) Won’t it get overwritten later on when an update is done?

Do I have to do a amportal a r ?

Every time a change is made to a .conf file, Asterisk must be reloaded for the change to take affect.

No dice. Did the amportal a r Dialed out and parked the call. Picking it up elsewhere I got the tone. :frowning:

I saw in another thread commenting out the courtesytone=beep line I might try that

Tried that no change

Tested the FreePBX “Pickup Courtesy Tone” setting with Asterisk versions 1.8, 11 and 13 and only Asterisk 13 allows me to suppress the tone for both parties when picking up a parked call. I’m not even sure that FreePBX is properly writing out the settings for parkedplay which is the parameter that controls which parties here the courtesy tone. In my very brief search, I found different sources gave ambiguous settings for this param.

I remember reading the same as you describe. That version 13 was the only one that had that ability. It seems like it might be a case of “Trying to nail jelly to a wall” type of thing. I will see if The James comes back with anything. Would I have to upgrade asterisk to 13 and FPBX to 13 to get this functionality? It seems like such a small feature to have. But it is very maddening to my customer. Albiet he waits almost two years to complain about it.

What if I created a new audio file with a moment of silence in it and set courtesytone=myfile ??

Might work, there are stock silence recordings in Asterisk, try “silence/1”.

I tried this

Changed courtesytone=sorrydave sorrydave is a ulaw file in the same folder as all the othere /en

Did the amportal a r

Still no go.

I went back to set the courtesy= back to beep and found that it was already changed. I used your suggestion and it was changed back again. I am surmising that the amportal a r sets it back to beep ugh

I think it might be time for a cold one for the day.

Just a thought before I go drown my sorrows. That file is owned by asterisk, what if I changed the owner or the permissions so only root can change that file. Asterisk could still read it, but not over write it.


asterisk -rx "core reload"

just to be sure asterisk is reloading

Also try changing it in the _additional.conf file. Note a reload will wipe that out so just use the asterisk command above

The order of how the features.conf loads #include files suggests that adding that option to :-


should override any incorrect setting stubbornly remaining in


I know that @jfinstrom said that previously, you will need to do the rasterisk -x “reload” thingy to set it of course , I would be surprised if that didn’t work . . .

Thanks dicko. I will try that out

Adding courtesytone=none in features_general_custom the system drops the call when retrieving it.