Park BLF always lights up with restphoneapps.. Getting errors in restapp.log?

Hello,

Just did a fresh install of 10.13.66-6. Restored backup from another physical machine which was upgraded to 10.13.66-6.

With new installation, parking is working, but once the light comes on, it never goes back off.

Getting these errors in the restapps.log.

[10-Jan-2016 13:34:59 America/New_York] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/modules/restapps/modules/restapps/apps.php on line 51
[10-Jan-2016 13:34:59 America/New_York] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/modules/endpoint/functions.inc/functions_general.php on line 83
[10-Jan-2016 13:34:59 America/New_York] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/modules/restapps/modules/restapps/apps.php on line 51
[10-Jan-2016 13:34:59 America/New_York] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/modules/endpoint/functions.inc/functions_general.php on line 83
[10-Jan-2016 13:34:59 America/New_York] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/admin/modules/restapps/modules/restapps/apps.php on line 51

[[email protected] ~]# fwconsole ma list
No repos specified, using: [standard,commercial] from last GUI settings

±---------------------±-------------±----------------------------------+
| Module | Version | Status |
±---------------------±-------------±----------------------------------+
| accountcodepreserve | | Not Installed (Locally available) |
| announcement | 13.0.4 | Enabled |
| areminder | 13.0.4.3 | Enabled |
| arimanager | | Not Installed (Locally available) |
| asterisk-cli | 13.0.3 | Enabled |
| asteriskinfo | 13.0.6 | Enabled |
| backup | 13.0.21.2 | Enabled |
| blacklist | 13.0.7 | Enabled |
| bria | 13.0.12 | Enabled |
| broadcast | 13.0.8 | Enabled |
| builtin | | Enabled |
| bulkdids | 13.0.2 | Enabled |
| bulkextensions | 13.0.3 | Enabled |
| bulkhandler | 13.0.13 | Enabled |
| callback | 13.0.4 | Enabled |
| callerid | 13.0.3 | Enabled |
| callforward | 13.0.4 | Enabled |
| calllimit | 13.0.3 | Enabled |
| callrecording | 13.0.8 | Enabled |
| callwaiting | 13.0.1 | Enabled |
| campon | 13.0.3 | Enabled |
| cdr | 13.0.20.1 | Enabled |
| cel | 13.0.14 | Enabled |
| certman | 13.0.12 | Enabled |
| cidlookup | 13.0.7 | Enabled |
| conferences | 13.0.15 | Enabled |
| conferencespro | 13.0.8 | Enabled |
| configedit | | Not Installed (Locally available) |
| contactmanager | 13.0.16 | Enabled |
| core | 13.0.29 | Enabled |
| cos | 13.0.9 | Enabled |
| customappsreg | 13.0.4.4 | Enabled |
| customcontexts | 13.0.2 | Enabled |
| cxpanel | 4.1.10 | Enabled |
| dahdiconfig | 13.0.9 | Enabled |
| dashboard | 13.0.17 | Enabled |
| daynight | 13.0.8 | Enabled |
| dictate | 13.0.4 | Enabled |
| digium_phones | 2.11.3.0 | Enabled |
| digiumaddoninstaller | 2.11.0.12 | Enabled |
| directory | 13.0.10 | Enabled |
| disa | 13.0.5 | Enabled |
| donotdisturb | 13.0.3 | Enabled |
| dundicheck | 2.11.0.3 | Enabled |
| endpoint | 13.0.2 | Enabled |
| endpointman | | Not Installed (Locally available) |
| extensionroutes | 13.0.5 | Enabled |
| fax | 13.0.24 | Enabled |
| faxpro | 13.0.26 | Enabled |
| featurecodeadmin | 13.0.5 | Enabled |
| findmefollow | 13.0.26 | Enabled |
| firewall | 13.0.14 | Enabled |
| framework | 13.0.49 | Enabled |
| freepbx_ha | 13.0.6 | Enabled |
| fw_langpacks | | Not Installed (Locally available) |
| hotelwakeup | 13.0.9 | Enabled |
| iaxsettings | 13.0.3 | Enabled |
| infoservices | 13.0.1 | Enabled |
| irc | 2.11.0.6 | Enabled |
| ivr | 13.0.14 | Enabled |
| javassh | 2.11.2 | Enabled |
| languages | 13.0.5 | Enabled |
| logfiles | 13.0.7 | Enabled |
| manager | 13.0.2.5 | Enabled |
| miscapps | 13.0.2.1 | Enabled |
| miscdests | 13.0.2 | Enabled |
| music | 13.0.12 | Enabled |
| outroutemsg | 13.0.2 | Enabled |
| paging | 13.0.11 | Enabled |
| pagingpro | 13.0.8 | Enabled |
| parking | 13.0.10 | Enabled |
| parkpro | 2.11.0.11 | Disabled |
| pbdirectory | 2.11.0.4 | Enabled |
| phonebook | 13.0.5.2 | Enabled |
| phpinfo | 13.0.2 | Enabled |
| pinsets | 13.0.4 | Enabled |
| pinsetspro | 2.11.0.9 | Disabled |
| presencestate | 13.0.4 | Enabled |
| printextensions | 13.0.3 | Enabled |
| queueprio | 13.0.2 | Enabled |
| queues | 13.0.15 | Enabled |
| qxact_reports | 13.0.8 | Enabled |
| recording_report | 13.0.14 | Enabled |
| recordings | 13.0.18 | Enabled |
| restapi | 13.0.13 | Enabled |
| restapps | 13.0.3.6 | Enabled |
| restart | | Not Installed (Locally available) |
| ringgroups | 13.0.9 | Enabled |
| setcid | 13.0.4 | Enabled |
| sipsettings | 13.0.15 | Enabled |
| sipstation | 13.0.13.7 | Enabled |
| sms | 13.0.4 | Enabled |
| sng_mcu | 13.0.3 | Enabled |
| soundlang | 13.0.6 | Enabled |
| speeddial | 2.11.0.3 | Enabled |
| superfecta | | Not Installed (Locally available) |
| sysadmin | 13.0.34 | Enabled |
| timeconditions | 13.0.14 | Enabled |
| tts | 13.0.6 | Enabled |
| ttsengines | 13.0.4.1 | Enabled |
| ucp | 13.0.21 | Enabled |
| ucpnode | 13.0.16 | Enabled |
| userman | 13.0.50 | Enabled |
| vmblast | 13.0.6 | Enabled |
| vmnotify | 13.0.8 | Enabled |
| voicemail | 13.0.31 | Enabled |
| voicemail_report | 13.0.5 | Enabled |
| vqplus | 13.0.16 | Enabled |
| weakpasswords | 13.0.1alpha1 | Enabled |
| webcallback | 13.0.8 | Enabled |
| webrtc | | Not Installed (Locally available) |
| xmpp | 13.0.6 | Enabled |
±---------------------±-------------±----------------------------------+

Restarting restapps fixes it until the next parked call.

-jr

Looks like it may be a bug in asterisk. Rest Apps, BLF, and Asterisk 13 Compatibility?

Thanks! Seems that I’m on the latest. Will need to wait for an update.

-jr

Saw that here. I solved it by rolling back to Asterisk 11. Works as expected after that.

13.7 will work as well

I just updated to latest 10.13.66-7 and still have BLF on with no calls parked. Restarting restapps does fix it for awhile.

-jr

Try rebooting the computer. I’m not sure why but it worked for me after a restart

1 Like

It has been working for me, but every day or so it will be stuck on red (parking BLF) and restarting the restapp will fix it. The dashboard will show a warning sign on rest apps. restarting it resets it back to green check mark. I’m going to upgrade again to latest.

I had rebooted machine.

Having the same problem here…
I’m on FreePBX 13.0.54
Upgraded Firmware from 6.12.65-31 through to 10.13.66-7 then the BLF always-on issue started to occur.

Having the same issues here after upgrading from 6.12 to 10.13. Distro and modules are all up to date. Voicemail, Call Flow and Parking BLFs are all not working correctly.

Has anyone found any answers or solutions yet?

What phone are you using?

Are you sure all your modules are updated currently? We made alot of permissions changes the last few days for phone apps to make them easier to control permissions user manager.

Running Aastra phones with current firmware. Distro is up to date, and all modules are up to date. Also running edge track.

After upgrading, I did change the permissions to allow access to the phone apps. For example, call flow and voicemail access works through the apps, but the BLFs don’t show the appropriate status. Sometimes they are stuck on, other times stuck off.

ps -A | grep restapps

[[email protected] ~]# ps -A | grep restapps
9458 ? 00:00:00 launch-restapps
9459 ? 00:00:00 restapps.php

I suggest you open a ticket up with commercial module support.

Thanks Andrew. I opened ticket 444153 on March 14th. We’ve been back and forth a few times, but I haven’t heard anything back in a couple weeks. Thought maybe in the community had some tips!

What is the status on this issue? It seems asterisk 13.11.x and higher along with asterisk 11.24.x in conjunction with phone apps module version 13.0.84.3 leaves the park app blf light on. If I park a call at least on the asterisk 11.24, the light flashes. Phones are yealink - T28, T46, etc. Customers get confused when we patch a system and the behavior of a basic function reverses itself overnight. Any idea where to look to troubleshoot this further?