PAP2T won't register after upgrade to beta FreePBX 2.9

I am new to FreePBX. I used the instructions and loaded the ISO on a standalone computer and hooked a PAP2T to it. After alot of tweaking I got everything working great. It worked for about 3 days perfectly. I was running I got a message that 1 module was due for an upgrade. It was framework I thought this would be painless and I found some instructions on how to upgrade. The instructions just said freepbx 2.8.1 so I thought it would give me the newest version. Instead it installed version and I had 59 modules ready for upgrade and an error about something being offline and it defaulting back to asterisk which could hurt performance. However I could still make calls. I saw the beta 2.9 version and figured I’d just upgrade to that to overwrite all these old files. Everything installed perfectly. I went thought the google voice setup like before. The administration screen looked good with everything greened up. However, it showed the current version as instead of 2.9. I figured at least I’m back to where I was before. But I’m not. I can’t get my PAP2T to register with the freebpx server. I put in the new password for the user id which asterisk generates so it’s not that. I don’t know what else would have changed. I’ve gone throught the settings over and over and not matter what I do it won’t register. Is it just the beta version?What am I missing? I’m sure it’s something simple. The upgarde instructions on this website say they take 15 seconds after the download and don’t interrupt service but the the instructions link is listed as broken and being updated. Can someone please help me first get my system back on line and second send me instrutions on how to correctily upgrade a module next time so I don’t have to go through this again. I greatly appreciate you assistance.

I reloaded the asterisk server from scratch with incrediblepbx and it worked instantly so you were right. I just won’t be able to update the modules using freepbx. Thanks again!

If the freepbx upgrade broke all of the custom goole voice scrips in incredible pbx that would explain why it quit working and nothing I’ve done can fix it. I guess I just need to reinstall my server from scratch. I really appreciate your help and will go to the incredible pbx forum for any additional assistnace.

I installed incredible PBX from I guess the version numbers are for it but it says free pbx when I log into it. I think incrediblepbx is a version of free pbx made to work with google voice.

Incredible PBX is just FreePBX provided by PBX in a Flash with a bunch of scripts.

You’d best go ask your questions on their forums:

As this isn’t the place to ask them here (specifically because you are asking about generated passwords)

It’s pretty much vanilla FreePBX 2.8 with extensions and trunks already setup to work with google voice. There is no other modification other than that.

Also I should mention when you use the incredible scripts you aren’t suppose to upgrade freepbx it will break all of the custom google voice scripts added to the custom config files because FreePBX 2.9 is different in several aspects than 2.9

I am not really sure what you are describing. FreePBX does not generate any type of accounts or secrets so I don’t know what you are describing.

You really need to start with the basics, is the PAP2 registering to Asterisk (look in the Asterisk Info Module or CLI command ‘sip show peers’. If it is not registered the extension and secret do not match between the PAP2 and FreePBX.

If the device is registering then something may have changed in the Google Talk config.

Certainly your experience is not common. How was the system originally build? You say you inserted the ISO, what ISO?