PAP2T, SPA112, Sipura (SPA3000) fail to register

I cannot connect to freepbx using PAP2T etc as an extension (generic SIP device). It refuses to register. I’m trying to set up freepbx first time. I can register other clients - all virtual - Csipsimple (android), Twinkle and Ekiga (ubuntu) and can make and receive external calls on them too.

Just a few more things i have tried:

  1. Factory resetting device
  2. Power cycle device

Some of my settings are as follows:

  1. I have tried using various ports. Matched it with the port in the extension settings as well as in the Asterisk SIP settings.
  2. ip address of freepbx machine is in the Proxy ( Both devices are on the same subnet.
  3. Outbound proxy is disabled.
  4. Userid is the extension number
  5. password is the one entered in the ‘secret’ in freepbx extension settings.

All other settings are the same as the factory defaults - havent changed anything.

The PAP2 says “Can’t connect to login server” the other two - Sipura and SPA112 just say “Failed”

I am using freepbx distro version (FreePBX

Any idea? please help. i have been struggling a long time… i have no clues how to proceed or debug . i tried to look up logs from the freepbx interface, but couldnt find out anything.
Have looked up this and other forums but no luck.

Thought i will update it here if someone faces the same problem… In the PAP2T etc there are two entries for port - SIP Port and EXT SIP port. I set the EXT Sip port to the port on which the trunk is registered (under ‘Asterisk SIP settings’) and the SIP port to the port number in the Extension settings(Applications>Extensions). Now it is working.