FreePBX | Register | Issues | Wiki | Portal | Support

Panasonic KX-TGP600 dont reconnect after Asterisk Restart


#1

Hello,
i have some Panasonic Phones by the customer, connected with TLS/SRTP LetsEncrypt.
Codec G711

Everything works.
The phones reconnect when the internet connection was lost but if i reboot the PBX or restart Asterisk then the phones do not reconnect anymore.

Sometimes they reconnect after a few hours but most times they dont reconnect forever. Also not after a day.
The customer has to reboot the basestation then they work.

What can be the reason for this?
We also installed some Yealink T48G and Cisco SPA112, they work perfect without any errors and reconnect within minutes.

Maybe someone also had this problems.


Panasonic KX-TGP500 DECT can dial out though unable to receive calls
(Alex DiMarzo) #2

There should be a SIP registration timeout value; set this to 60-120s

This screenshot calls it “REGISTER Expires Timer”


#3

Hello Overkill,

thank you for the posting.
I have set this value to 120.

Today i made a Asterisk Upgrade to the latest version.

4 Panasonic phone came up after the Reboot of FreePBX and 2 Panasonic Phones did not connect anymore. The customer needs to plug the AC Adapter out and restart them manually. Everytime it is a gamble with the TGP-600 if they come up or not.

Phones are Connected with TLS/SRTP Letsencrypt cert. The customer also has some SPA112 Adapters and Yealink T48S Phones, but they work perfectly without any problems. They instandly reconnect after the reboot of the PBX.

I found another Value:
Supports Session Timer (RFC 4028)
SIP_SESSION_TIME_[1–8]

I set this now from “Disabled” (0) to the value 1800 seconds.

Maybe this solves the problems


(Alex DiMarzo) #4

Try a lower value, maybe 60?

Also, is the firmware version on the phones the latest available? There may be a bug.

Lastly, are you able to see the phones attempting to register in the logs?


#5

I will give you feedback when i know if a lower value worked.

Today i came across that the phone with asterisk state “UNKNOWN” or “UNREACHABLE” called me on the phone.

So it is a RTP issue with external phones. The RTP Ports are “0” and the phones are not registred anymore.
But the basestation by the customer had a green lamp and signaled that everything is fine.

The latest firmware is already installed.


(Alex DiMarzo) #6

Those timers you changed are for calls - session timers are basically an “If I have an active call, hang it up after __ time if I don’t get any messages from the server.”

What edge device do you have as your router? This could be a weird NAT issue.


#7

You are right. The settings did not help.

All customers have a Thomson TG585 Router.
In one of the stores, there is a business DSL with a Cisco Router. But for the issue it is the same everywhere.
The PBX is in the Cloud on a KVM Server. So everything works with NAT and RPORT.

One of the Extensions is “Unreachable” since over 5 days but the customer still makes outside call from the phone.
The Basestation need to be restarted by unpluging the AC.

My next try is:
PORT_PUNCH_INTVL="60"
RTP_PORT_PUNCH_INTVL=“60”

They where set to “0” before.


#8

I think i have found the issue.

Sangoma has set this Values
SIP_ADD_RPORT_N (N=1-6)

This values dont exist, because it is a global value!
The right Value is
SIP_ADD_RPORT=Y (or N)

The only way was to let Panasonic TGP600 recognizing that the connection is lost, is setting this to "Y"
This Setting Refers to rfc3581

In my case!! I use TLS/SRTP and all Phones are external Phones.(NAT)

Snom has this Value enabled by default.

btw. the new Firmware. 06.001, which released a few weeks ago solves also a lot of issues with Randorm Ports. TGP600 sometimes used Random Port “0”, which is resolved now with this firmware.


#9

Okay it worked a few hours…

When i reboot the PBX, the Phone only recognizes a connection Lost about 5-10 Minutes after first Registration. Then most times when i reboot the PBX later the Lamps stay Green and the Phones says “Registred”. The state in Asterisk changes to “Unknown”

Now i think this must be a issue with the TLS Connection of Panasonic. I tried it with TLS and SIPS-TLS.
Both have the same Problem.

If i change to UDP/SRTP everything seems to work until now. But it is not secure as TLS/SRTP, which works well with Yealink and Snom Phones. But i did not find any DECT device which can handle this without issues. Also not Snoms M700.


#10

For posterity’s sake, I was having the same problem.

However, I set the REG_EXPIRE_TIME_n to 15s, down from the default 3600s. That seems to have done the trick.

I’ll play with the numbers and see if the phone can call home less frequently, but still stay online.


#11

For me the only solution was the connection with UDP/SRTP
TLS can work over weeks but then it will loose the connection anytime and you have to reboot the base station.


#12

@mitterhuemer
FWIW, that sounds like it might be an issue with time sync. If the server and base station’s time are off by a large enough margin, TLS will break. (As I seem to recall).