Paging with Grandstream Phones

I have a paging group setup with Duplex NOT CHECKED but when I page it is an intercom with full two way conversation with all phones.

I am using Grandstream GXP2124’s with the “Allow Auto Answer by Call-Info” set to yes.

So two problems.

  1. If I just do the page but don’t actually say anything but hang up quickly, the other phones don’t hangup.
  2. The Duplex problem where the call is always INTERCOM and not PAGE. The mics on the phones are turned on.

DOES ANYONE HAVE THE PAGING STUFF WORKING CORRECTLY?

Thanks,
Mark

We use Grandstream phones exclusively (about 380 of them) and paging groups are set up and working quite well on our system.

First - Busy extensions - skip / duplex - unchecked / default page group - unchecked

Make sure your firmware level on the phones is reasonable… earlier versions have weird issues, some paging related. I suggest Version 1.0.5.58

I would upgrade and default the phone settings. The default settings work fine for paging.

Also, what version of freepbx are you using?

Here are some issues - most pages will hang up properly, but every one in a while, one will not release. I’m using app_confbridge, but some have suggested app_meetme as the Conference Room App in settings/advanced settings/Conference Room App.

If you have a page that hangs, it’s pretty easy to fix -

Login to your asterisk CLI console - Goto Admin - Asterisk CLI
asterisk2CLI> core show channels
Channel Location State Application(Data)
SIP/3224-00000a19 [email protected]:42 Up Dial(SIP/4027,15,trI)
IAX2/IAX_Trunk_to_US (None) Up AppDial((Outgoing Line))
SIP/4003-00000a2f [email protected] Up Dial(IAX2/IAX_Trunk_to_US/1001
SIP/4001-0000089e [email protected] Up VoiceMail([email protected],u"")
SIP/3117-00000102 [email protected]: Up VoiceMail([email protected],u"")
SIP/4027-00000a1a (None) Up AppDial((Outgoing Line))
6 active channels
4 active calls
1553 calls processed
As you can see in my case there are 4 active channels and I want to disconnect user 4003 for example.
asterisk2
CLI> channel request hangup SIP/4003-00000a2f
Requested Hangup on channel ‘SIP/4003-00000a30’
– Executing [[email protected]:1] Macro(“SIP/4003-00000a30”, “hangupcall,”) in new stack
– Executing [[email protected]all:1] GotoIf(“SIP/4003-00000a30”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“SIP/4003-00000a30”, “0? Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“SIP/4003-00000a30”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/4003-00000a30’ in macro hangupcall’
== Spawn extension (macro-dialout-trunk, h, 1) exited non-zero on ‘SIP/4003-00000a30’
– Hungup 'IAX2/IAX_Trunk_to_US-49’
Now user 4003 has been disconnected as you can verify below.
asterisk2*CLI> core show channels
Channel Location State Application(Data)
SIP/3224-00000a19 [email protected]:42 Up Dial(SIP/4027,15,trI)
SIP/4001-0000089e [email protected] Up VoiceMail([email protected],u"")
SIP/3117-00000102 [email protected]: Up VoiceMail([email protected],u"")
SIP/4027-00000a1a (None) Up AppDial((Outgoing Line))
4 active channels
3 active calls
1554 calls processed

1 Like

Thanks for the detailed response!

FreePBX version is 2.11.0.38
It is users and devices mode.

Phones are on version 1.0.6.11

I only have 12 gxp2124’s and a few soft phones on android devices and desktops.

I don’t think I had any conference software loaded back when I was testing the paging. I have since installed the standard Schmooze “Conferences” module but have not yet used it other than a simple test. Does the paging use the conference capability to do the page?

Thanks again,
Mark

It’s using a confrence app for the paging functionality

I just upgraded to freepbx 12 in hope that it would fix my paging problem. It did not.

I am still paging in full duplex, like an intercom.

I think next week I am going to factory reset a phone and only change the auto answer setting and see if that fixes the problem. I am not changing many settings on the phone but who knows…

Does anyone know how the paging app controls the mic? Is it on the phone or is it muting the extension via the pbx?

-Mark

Really old thread but I thought I’d share the answer I found to paging on Grandstream phones. I tried to get the built-in Grandstream multicasting working but couldn’t. Then I stumbled on this old post:

GXP2130 And Intercom Mode

Worked right away and really easy to setup. Of course the two phone settings would have driven me insane trying to figure out. So many thanks anomaly0617.

Duplicating instructions in case that link goes away. This is Grandstream specific but might help others:

Install the Paging and Intercom module in Asterisk and configure a paging extension.
    In your Grandstream phone:
    Under Accounts - Account X - Call Settings
         Allow Auto Answer by Call-Info to Yes
         Custom Call-Info for Auto Answer to answer-after=0 (no quotes).
    Under Settings - Programmable Keys
         Set one of your MPKs like this:
               Mode = Busy Lamp Field (BLF)
               Account = Account X
               Description = All Page
               Value = [Defined Paging Extension]

BTW regarding Grandstream bugs, I’ve had to update the firmware to the latest beta 1.0.7.13 firmware to fix some issues.

1 Like

Really old posting here. Nonetheless an update:

I updated my Grandstream 2130s to firmware 1.0.9.26 and found this setting no longer applies. Now, leave “Call-Info For Auto Answer” blank. The setting above no longer works.