Paging Pro Module playing tone on schedule not hanging up


(David) #1

I have installed The commercial module Paging Pro to gain the ability to create schedules and replace our schools dying bell system. I have created a test with a Grandstream GXP 1615 and a SNom PA1, both configured as SIP clients with extensions.

I have created a paging group (4200) with these 2 extensions, uploaded an alert tone file, and set a schedule.

It will play the tone over the speakerphone and PA1 at the scheduled time, but the page does not disconnect. The phone shows the call still connected “Talking Test 4200 PCMU”. I have left it for quite some time, and it does not disconnnect. You have to end the call at the handset.

System info:
Current PBX Version: 14.0.13.34
Current System Version: 12.7.6-2002-2.sng7


(Tony Guadagno) #2

is this your issue?
https://issues.freepbx.org/browse/FREEPBX-15580


#3

Assuming you’re not experiencing an issue that tonyg linked to and disregarding the scheduling for now, what happens when you try calling the page group? Do the receiving devices remain off hook after the caller hangs up? If so, there might be some settings worth looking at for your devices. I don’t have Grandstreams or a Snom PA1 to play with, but there does seem to be relevant settings that could be worth looking into.

Grandstream: https://www.grandstream.com/sites/default/files/Faq/gxp_interop_asterisk.pdf (see Turn off speaker on remote disconnect)

Snom PA1: http://downloads.snom.net/documentation/UM_PA1_en.pdf (see Automatic Termination of Calls section)


(David) #4

This was more of less my issue Tony, thanks! Once I moved the recording to the “Page Announcement” which had previously been empty, the call plays the recorded file and disconnects the call. So anyone who runs across this post with the same issue, if you have a recording file in the “Alert Tone” only, it will not disconnect the call.