Paging group 'stuck' open when original extension hung up

Trying to do a paging group via the CLI using the below method

rasterisk -x 'channel originate local/[email protected] extension *[email protected]'

where 101 is the paging group and 24 is a local extension.

What I’m finding is that the paging group isn’t closing naturally when extension 24 ends the call. Sometimes the other extensions still show as being part of an ongoing paging call and sometimes they don’t. Both whether the other extensions show as being on the call or not, the paging group doesn’t close of its own accord unfortunately.

Any help much appreciated on how to workaround or fix this.


These are the open channels

Local/[email protected];1
Local/[email protected];2
Local/[email protected];1
Local/[email protected];2
Local/[email protected];1
Local/[email protected];2

Seems very similar to this issue and this one too I guess

@lgaetz sorry to ping you directly - should I log this as a bug?
Basically the page group doesn’t close automatically (even after a 30s delay!) when the target/initiating extension rings off.

do you get the same result if you reverse the order of the channel setup?

channel originate local/*[email protected] extension [email protected]

Had a similar problem. I corrected it by add a white noise (silence) about 15 second long. Now any page announcement is over 15 second long

Yep, same result

not sure how that would help as this isn’t an announcement - or am I missing something?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.