P310 http provisioning?


#1

Looking to upgrade from the s206 to get some better quality audio so testing out the P310 - and while I’ve configured it to pick up DHCP option 66 it would appear these don’t support TFTP config?
I’ve tried setting the option 66 URL of HTTP://ipaddress:84 but its not working… tried a variety of other variants but no luck so far… anyone know what format this should be in? I’ve toyed with the idea of doing the 0 touch deployment so registered for that too

https://wiki.freepbx.org/display/PHON/Setup+Phone+with+DHCP+Option+66
notes that the Note: http username & password could found in System Admin > Provisioning Protocols

I don’t have a Provisioning protocols.
FreePBX 15.0.17.34


(Jared Busch) #2

That is part of SysAdmin Pro


#3

Ah right - thanks! but i would think it shouldn’t be needed to purchase the module to get a p310 provisioned. Right?


#4

It’s not ‘needed’ but you will have to otherwise create your own provisioning files and serve them out through whatever protocol your phone is set to use.


(Itzik) #5

Am I misreading OPs question? You set the provisioning protocol in the EPM template. Provisioning ports you set in SysAdmin, http provisioning auth you set in SysAdmin pro.


(Dave Burgess) #6

There might be an option to do that, but it certainly isn’t the only way to accomplish this. Since the OP is not using a Sangoma product, EPM is a paid product, but Sysadmin Pro is not assumed to be part of the process either way, so it would be up to the OP to set up the authorization process themselves in whatever provisioning process they use.


#7

Maybe another way to ask this question is - can the Sangoma/Digium P310 phone be provisioned without using http e.g. TFTP, and/or is it possible to use http without username/password?


(Itzik) #8

The P310 is a Sangoma product.


(Itzik) #9

Yes, but IMO, don’t use tftp. Use http or even better, https.

Yes, you can use http/https provisioning without apache auth.


#10

So - after going down the path of seeing if DPMA was needed on the Sangoma/Digium P310 I landed back on this screen and noticed that the account portion hadn’t saved:

So I add it back again, hit save, reprovision the devices, and bam it works. Now if only I could get those 3 hours back.

Going back to the same page it still shows that Account blank so a glitch with EPM it would appear. :frowning:

So in the end my issue had nothing to do with http/tftp…


(system) closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.