P Series cutting off audio at beginning of sentence

I’m noticing that during call ringing and at the beginning of sentences after silence, the receive audio is cut and fades in. This is causing our users to miss the beginning of their greeting like “Hello Mike” comes though as just “ike”. I would imagine this is from the echo cancellation or background noise suppression too aggressive. Is there any way to change this? I don’t see anything in the XML or FreePBX EPM config.

EDIT: This is happening with P series phones, specifically, P330 and P370.

I’ve not seen any reports similar to this for P phones. Do you have other endpoints in the same environment that don’t have this issue? How have you narrowed it down to the desk phone?

What you’re describing was something I ran into on systems using POTS lines for trunks, I assume that’s not the case here is it?

I have another system for my business with a P370 that was doing the same thing. I have a SIP trunk for both.

The original system im referencing is calling another connected VoIP system (Avaya IP Office) over a sip trunk to other local phones.

I just switched from G722 to ulaw on that system and waiting to hear back from the users to see if it makes a difference at all.

1 Like

It’s doing the same thing. Testing from my office phone does a similar thing when dialing. I made an audio recording: Synology Drive

It doesn’t always happen, but it’s a similar action when I’m dialing, the audio fades in. Also on the 1st ring, it fades in. So when the other party picks up, “hello” is too quick and it takes too long to fade in, so it’s missed. It’s happened to me a bunch too, but I don’t make that many outbound calls.

For testing, would there be a way to disable background noise and echo cancellation?

I don’t see what you’re referring to in the provided recording but at this point I will ask that you open a support ticket and work with support to debug this. They will want to get a pcap and a phone pstr at the same time so that engineering get get an accurate picture of what’s going on.

1 Like

Thanks Lorne. I just opened a ticket about it. To add, this wasn’t happening with an S series phone. When I switched to my P370, I noticed it on the 1st call, no other changes to the FreePBX install other than enabling support for the P series. If I get a resolution, I’ll post in here.

1 Like