OVH trunk - Outbound CallerID


(Marc) #1

Hi

I have setup a trunk from OVH. (pjsip)
Incoming calls are OK. A specific context was required: “from-pstn-toheader” to get the incoming CallerID.
Outgoing calls are going out, but…

I can not find any working configuration to get the outgoing CallerID to the destination phone.

I do have it working fine with other trunk providers.

Any clue.

OVH support made me change the supported codecs on their side ?? No change.
OVH support asked me to use a softphone to check. I did with Zoiper Pro on PC. No change.


Incoming calls problem \ ovh provider
(Ricardo) #2

Well Caller ID is set by providers (CID on network have additional information as Carrier operator ID, etc.), due to security and appraising.


(Marc) #3

In my case, I’m theoretically allowed to present a number between those provided by OVH to me or one validated by a procedure (answering a call to that number with a onetime pin code).
While presenting one of these numbers it should appear on the other side.
I’m looking for some special requirements with this operator as it works fine with others. I can set the callerID on other trunks from the same (and other as well) freepbx server.


(Ricardo) #4

If so that, better to work with OVH and analysing debug trace log.


(Marc) #5

I agree. Not easy though. I ony have my logs. not theirs


#6

That sounds very strange. What from-pstn-toheader does is fetch the called number from the To header (rather than the SIP URI), allowing your Inbound Routes to work properly, based on number called. It does not affect the calling number at all.

Great. So tell us exactly how you set the outbound caller ID in Zoiper and we’ll try to do the equivalent in FreePBX.


(Marc) #7

No way to get the CID (variable CID depending on the route or the extension etc.) out via OVH trunk. Zoiper or Freepbx same result.
Only CID displayed is the fixed CID set through OVH trunk settings or anonymous.

There must be a setting I have not found yet. :disappointed:
No useful help from OVH.

No problem at all with an OpenIP trunk. No special context. Just like expected.
I’m still getting inbound through OVH but will switch to OpenIP asap.


(system) closed #8

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.