Outside extension. sometimes 'SIP/.. is ringing' and sometime not

Hi all,

I’m using FreePBX with some extensions that are outdise my LAN.
All extensions outside my LAN are working great exept 5007.

Extension 5007 is located in a hotel apartment in Kuala Lumpur.

Calling from 5007 to a real phone number is working 100%
Calling from 5007 to an other extension (lets say 5005) does sometime work and sometime not.

Same thing when calling from 5005 to 5007. Sometimes it’s working and sometimes not.

To make a working connection from extension 5007 or to 5007 I have to call the extension several times.
It’s only the 5007 extension that is having this problem. Any of the other extensions that are outside the LAN do not have this problem.

Looking at the Asteris CLI, I do see when calling 5007: – Called 5007
And sometimes (could be 5 seconds later): – SIP/5007-000003aa is ringing
When the ringing is showing, 5007 does actualy ring.
However sometimes it’s only showing: – Called 5007
and NOT the ringin part.

The strange thing is that calling 5007 does work sometimes in one go, and sometimes after XX tries.

Anyone here who might know what could be causing this strange behavior, and how I could fix this?

Please note that I do not have access to the hotels “firewall” :slight_smile:
Also that I needed to set 5007’s qualify to NO as the ping is really high.

do you have NAT=yes for extension 5007’s configuration?

This might be a clue also:

Also that I needed to set 5007’s qualify to NO as the ping is really high.

If the ping is high then you could be timing out due to the delay.


Yes NAT is set to yes.

Does this also count for the “SIP/5007-000003aa is ringing” part?
When I do have a connection with 5007, the connection is perfect.
Also doing an echo test from 5007, it is also perfect.

Thank you for helping.

your firewall pin hole is closing and blocking the call until next time the phone registered or makes a call, at which point it is open until the firewall closes it again.

If the phone has a “keep-alive” style option as some do, turn it on. If not, set the registration time down on the phone. Depending on the firewall, it may need to be 1 minute or less.

The qualify=yes on the phone can help with this but is the wrong approach. It will keep the pin hole open as long as the pin hole is open when the ping comes from Asterisk. By setting an equivalent on the phone (as just mentioned), it will always get through so if the hole ever does close for some reason, it will get re-opened as it is not in the times you are successful calling.

That sounds all logical.

Later today I will see if I can get the person at 5007 to “find” and “set” the keep-alive to 1 minute on the phone (Targa DIP 450)

Once again thank you for helpig.