Outgoing Fax Problems


got some really weird Problem with my favourite Topic (ironic) Fax.
We got a Fritz!Box connected via SIP to an ansterisk server which uses DAHDI for external calls.
When i try to send a fax from an analog fax,which is connected to the fritz, to an external Fax it rings 1 or 2 times and then asterisk hung up.
when i use a SIP connection on the asterisk for external calls and try the same all works fine.

I don’t know where to start to solve the Problem, because there is no anomaly vissible in the CLI i just receive a HUNG UP.

Setting :

FAX --(analog)–> Fritz!Box -----(SIP)------> Freepbx -----(DAHDI)------> World (not working)
FAX --(analog)–> Fritz!Box -----(SIP)------> Freepbx -----(SIP)------> World (working)

I did a little testing here.
If i use an an SPA or FRITZ!Box with an analog fax and connect it via SIP to the FreePBX-Server and try to send a fax i get a busy and a Hangup (code = 28).
This happens only when the FreePBX tries to send the FAX with DAHDI. If it is sent with SIP then everything works.

If i got the following constellation it works too :

FAX ( analog) —>SPA112------ SIP----> FreePBX---- IAX2 ------> FreePBX----- DAHDI----> World

i got it now.

i applied in the sip_general_custom.com “faxdetect=no” and everything worked like a charm.

i noticed in the cli output that everytime when i wanted to send a fax, that there was a warning “Fax CNG detected, but no Fax extension…”.
So i deactivated the faxdetection and tadaaaaaaaa it worked.

Sounds weird but somethimes it is like that.