Outgoing calls work but incoming do not port 5060 is closed

Im using freepbx with an OBI 110 to manage a POTS service I can make outgoing calls but incoming calls do not ring. The web based management interface is working

The obi110 call log shows the following failed call (I gave up after about 10 rings).:

Call 20 07/09/2015 12:09:16

Terminal ID LINE1 PHONE1
Peer Name my name
Peer Number xxxxxxxxxx
Direction Inbound Inbound
12:09:16 Ringing
12:09:25 End Call

The phones never actually rang

SIP2 Status shows Register Failed: No Response From Server (server:5060=xxx.xxx.xxx.xxx; retry in 7s)

The freepbx web overview shows that my trunk is down I don’t know why. Should outgoing calls work if the trunk is down? I flushed my firewall just in case that was the issue.
sudo netstat -ntulp
Shows the following:

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0* LISTEN 2187/sendmail: MTA:
tcp 0 0* LISTEN 9154/asterisk
tcp 0 0* LISTEN 1986/nrservice
tcp 0 0* LISTEN 9154/asterisk
tcp 0 0* LISTEN 2396/apache2
tcp 0 0* LISTEN 1695/sshd
tcp 0 0* LISTEN 915/cupsd
tcp 0 0* LISTEN 9154/asterisk
tcp 0 0* LISTEN 9154/asterisk
tcp 0 0* LISTEN 2187/sendmail: MTA:
tcp 0 0* LISTEN 2002/pptpd
tcp 0 0* LISTEN 2867/perl
tcp 0 0* LISTEN 2021/mysqld
tcp6 0 0 :::22 :::* LISTEN 1695/sshd
udp 0 0* 9154/asterisk
udp 0 0* 9154/asterisk
udp 0 0* 898/avahi-daemon: r
udp 0 0* 9154/asterisk
udp 0 0* 898/avahi-daemon: r
udp 0 0* 9154/asterisk
udp 0 0* 11660/cups-browsed
udp 0 0* 2867/perl
udp6 0 0 :::59498 :::* 898/avahi-daemon: r
udp6 0 0 :::5353 :::* 898/avahi-daemon: r

I’ve been through my set up several times and It’s very close to this guide wiki.freepbx.org/pages/viewpage.action?pageId=4161594. I’ve been fighting it for 3 days or so and I’m currently at a loss

Your Obi is trying to register on UDP/5060, but you don’t have anything listening, you do have asterisk listening on 5000 and 5061.

Well, ports 5000 and 5061 are both open and I have a trunk, an incoming port and and outgoing port. One of the concerns I have is that neither of the two guides I used to set this up show anything in the incoming settings of the trunk. It seems odd but given that one of the guides is in the freepbx.org wiki it’s hard to justify making something up for those settings.

That said, my netstat shows asterisk listening on both ports 5000 and 5061.

But by default SIP will listen on 5060 (or 5060 and 5061 if you have pjsip) and that’s what your Obi is trying to communicate to your box on. (5000 is generally used by asterisk’s unistim channel driver)

I’m most certainly an asterisk newbie. So as much as I appreciate your assistance, which I do, you are talking over my head. What it sounds like to me is that you are saying I’ve made a configuration error somewhere that has me listening on the wrong port. Alternatively I could have a deeper issue with my freepbx install. So is there somewhere in particular I should look?

Well, unless you intentionally changed SIP to use udp/5000 or you manually installed FreePBX with unistim I don’t really know, the question would be

How did you install FreePBX , by what method and on what platform?

I’m running Ubuntu 14.04 server on an intel atom based box with software raid 1. I used this to install freepbx:

cd /root
wget xxxx://incrediblepbx.com/incrediblepbx12.tar.gz
tar zxvf incrediblepbx12.tar.gz
rm incrediblepbx12.tar.gz

note: i had to modify the second line in the above because new users can’t post links.

You are not running FreePBX. You need the PBX in a Flash forum.

Yeah, just figured that out thx.

1 Like

Problem is I joined the pbx in a flash forum but I “have insufficent privileges to post” there