Outgoing calls / registration timer problem with FreePBX

I have a problem when making outgoing calls through a SIP trunk.

FreePBX is not registering often enough, and outgoing calls are being passed through to the SIP provider and being rejected (403: Unauthorized) as the registration period has expired.

I have queried the desired setting, scanned the forums and attempted to apply the following settings in incoming/outgoing settings in the trunk:

minexpiry=60
regseconds=60
defaultexpiry=60

Different posts seem to say different things. Can someone please point me at the correct setting? And am I entering it in the correct place?? (Trunks > TRUNKNAME > Outgoing Settings > Peer Details

After large amounts of hair was lost, and many cups of coffee consumed - The problem appear as 2 separate issues.

The first, was to add a ‘register string’ of TRUNK#:[email protected]/TRUNK# to my trunk.

The second was to modify Register timings in General Settings > SIP Settings, to register more often.