Outgoing call won't work


I am currently unable to place outbound calls, even though the trunk is registered and incoming calls work fine.

I’ve looked at both the asterisk and SIP debug logs and this error message comes up:

[2015-11-01 16:43:26] WARNING[4225][C-00000010]: chan_sip.c:23335 handle_response_invite: Received response: “Forbidden” from ‘sip:[email protected];tag=as59faa608’
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:24] NoOp(“SIP/125-00000020”, “Dial failed for some reason with DIALSTATUS = CHANUNAVAIL and HANGUPCAUSE = 21”) in new stack
– Executing [[email protected]:25] GotoIf(“SIP/125-00000020”, “0?continue,1:s-CHANUNAVAIL,1”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
– Executing [s-[email protected]:1] Set(“SIP/125-00000020”, “RC=21”) in new stack
– Executing [[email protected]:2] Goto(“SIP/125-00000020”, “21,1”) in new stack
– Goto (macro-dialout-trunk,21,1)
– Executing [[email protected]:1] Goto(“SIP/125-00000020”, “continue,1”) in new stack
– Goto (macro-dialout-trunk,continue,1)
– Executing [[email protected]:1] NoOp(“SIP/125-00000020”, “TRUNK Dial failed due to CHANUNAVAIL HANGUPCAUSE: 21 - failing through to other trunks”) in new stack

I suspect the cause of the problem is related to that “Forbidden” error. I’ve looked all over but couldn’t figure out what might be the cause.

Here’s the log from which the excerpt is from:


Any clue on what might be causing the issue?

Thank you.

Pleae check this feedback:

Who is your SIP provider?

My provider is Voip.ms

Make sure there is a balance in the account.

Make sure the registration string is correct: User:[email protected]
server must be the one where the DID is registered.

Why are you not using IAX2 to connect to voip.ms?


Are you sure there is not a mistake in your VoIP.ms trunk outgoing settings (a bad account/subaccount name or a bad password, etc…)

I suggest you take a look at their wiki. See http://wiki.voip.ms/article/FreePBX_/_PBX_in_a_Flash

If all else fails, they are usually quite responsive (they are one of the VoIP providers I use…).

Good luck and have a nice day!


The problem is solved. It turned out my boss provided me with a bad password.
Thank you!

De rien! / You are welcome!