Outbount Caller ID problem

Hi,

We are using a Xorcom BRI 8 external gateway connected to 6 ISDN2e Channels.

I have tried setting a number in both the trunk and the extensions for outbound caller id but the system is not sending either.

The number that is being sent is the default ISDN group number. The number I am trying to send is one of our DDI’s.

I have tried entering the number within <> and without, i have also tried it with and without the area code prefix. None of which work.

If i do not set any number the default ISDN group number is still sent.

Previously we were using an internal Digium BRI card with a custom MISDN trunk. Everything worked fine with that and has only just stopped working since we moved to a ZAP trunk.

Therefore i am 100% sure that BT ( our telco ) have the right settings so we can send outbound caller id.

Also we use several DDI numbers to route inbound calls to different departments and all this works fine as well as the system displaying the inbound caller ID on our handsets.

It is only outbound Caller ID that isn’t working.

Any help on this would be very much appreciated.

Thanks…Pigsfoot

I have recently moved to another carrier (X/O who apparently blocks outbound calls if the caller ID does not match one of the DID’s or BTN.
The problem is that during a follow me call, if the call was placed outside the acceptable # range for the account, the calls will fail as the originator’s caller ID is being delivered. The same thing occurs if the extension sets up call forwarding and an outside caller gets directed.
I have tried configuring CWID in Trixbox (Extension) but that only seems to be effective when originating SIP calls.
Any ideas how to get the outbound caller ID to send the extension # instead of the originating end’s caller ID?
Thanks much in advance.
Lu

Set the CID in your trunk definition, then check the “never override” box. Unfortunately, this only allows you to outpulse your main number in situations like that, but it does not impact any caller ID settings you’ve made in your extensions.

Thanks for the quick reply.
I did add the CWID and checked “never override” box but I still cannot get
the call through.
It however seems that the CWID is correct now but something else is wrong now…
I xxxx out the number sfor privacy concerns:
– Stopped music on hold on Local/RG-702784xxxx-954695xxxx#@from-internal-dbbd,2
– Executing [[email protected]:11] Set(“Local/RG-702784xxxx-954695xxxx#@from-internal-dbbd,2”, “DIALSTATUS=CHANUNAVAIL”) in new stack
== Auto fallthrough, channel ‘Local/RG-702784xxxx-954695xxxx#@from-internal-dbbd,2’ status is ‘CHANUNAVAIL’
– Local/RG-7027844xxxx-954695xxxx#@from-internal-dbbd,1 is circuit-busy

Not sure why I would be getting all circuits busy?

Turn on PRI debugging, it might help you figure that out. Just in case you don’t know how, do:

pri set debug span 1

(or whatever span your XO connection is on.)

It’s going to throw a lot of information on the screen, but if you dig through, it might have a clue why its still rejecting the call.

I use XO at two locations. All I had to do was set the “never override” option and put in our main BTN in the box.

From extensions I then set the full 10 digit number, with the did at the end for the individual CID and it gets sent correctly.

I may not be fully understanding your issue.

Well I thought the first recommendation you has mentioned took place, but apparently (being only on day 6 on Asteriks) I misunderstood to trace and I still see the same issue.
The caller ID is still passing on the orgination end.
So something apparently is wrong with the setting not taking place.
Is there perhaps a procedure I must implement to allow the action to take place other than apply?
I did try a manual “exten => 1234,1,Set(CALLERID(num)=7027841234)” as a work around and it does work, but of course I would like to use the GUI as much as possible.
I am still trying to press XO to fix their issue, not sure how much luck I will have, but I am prepared to move to someone else if they resist.
Have you heard of anyone else having sucess in their carrier in passing on the CID?

I think I am doing it the way you indicated, but I am not clear on what you mean by " From extensions I then set the full 10 digit number, with the did at the end for the individual CID "
So should I be putting in 70278412341234?
Currently I have User Extension & Outbound CID set to 7027841234 and I have the Trunks set to:
Outbound Caller ID 7027841234
Never Override CallerID is checked.

Anything else I need to do?
It still sends my orginating Caller ID when follow me or call forwarding is implemented.
You can email me directly at luvencl at hot mail dot com

Thanks.

:

Yeah, set it as just the 10 digit number. Sorry that was confusing.

Something else you should check is to make sure you’re entering the CID in the proper format:


"User Name" <8005551212>

If you’re just entering the number it’s not going to work.

Exactly as enterered in the subject title with quotes.
Using FreePBX GUI.
Was looking forward to final resolution, but still not sending correct CID.
There must be something else wrong where the field is not being looked at or recognized.
Here is a sample log…

– Goto (macro-user-callerid,s,6)
– Executing [[email protected]:6] NoOp(“Zap/1-1”, “REALCALLERIDNUM is 9544801234”) in new stack
– Executing [[email protected]:7] Set(“Zap/1-1”, “AMPUSER=”) in new stack
– Executing [[email protected]:8] Set(“Zap/1-1”, “AMPUSERCIDNAME=”) in new stack
– Executing [[email protected]:9] GotoIf(“Zap/1-1”, “1?report”) in new stack
– Goto (macro-user-callerid,s,13)
– Executing [[email protected]:13] NoOp(“Zap/1-1”, “TTL: 64 ARG1: SKIPTTL”) in new stack
– Executing [[email protected]:14] GotoIf(“Zap/1-1”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,23)
– Executing [[email protected]:23] NoOp(“Zap/1-1”, “Using CallerID “9544801234” <9544801234>”) in new stack
– Executing [[email protected]:2] Set(“Zap/1-1”, “VMGAIN=”"") in new stack
– Executing [[email protected]:3] GotoIf(“Zap/1-1”, “1?vmx|1”) in new stack
– Goto (macro-vm,vmx,1)
– Executing [[email protected]:1] GotoIf(“Zap/1-1”, “0?s-BUSY|1”) in new stack
– Executing [[email protected]:2] Set(“Zap/1-1”, “MODE=busy”) in new stack
– Executing [[email protected]:3] GotoIf(“Zap/1-1”, “1?notdirect”) in new stack