Outboundproxy issues on FreePBX Distro 5.211.65 with Asterisk 11, FreePBX 2.11, DAHDI 2.8 and CentOS

I’ve been trying to track down why a sip trunk isn’t registering and am starting to wonder if the outbound proxy isn’t working? As far as the SIP debug logs show it doesn’t show any signs of using the outboundproxy setting…

Internet research shows some older posts saying that it might be an issue with Asterisk compatibility — I’m using v11 and haven’t tried any other versions.

PEER
type=peer
username=773xxxxxxxxx
secret=xxxxxxx
qualify=yes
outboundproxy=208.90.249.3
insecure=no
host=strata8.net
fromdomain=strata8.net
canreinvite=no
srvlookup=yes
;defaultexpiry=7200
dtmfmode=inbound
dtmf=auto
context=from-trunk

USER
type=peer
host=strata8.net
context=from-pstn

REGISTER
773xxxxx:[email protected]

The logs show a failed address info on strata8.net — but the provider tells me that shouldn’t be necessary as that is an internal domain and thus requires use of the outbound proxy…

Every other provider I’ve worked with has just needed the host entry… so unfamiliar with the outboundproxy setting

SIP DEBUG LOGS:
[2014-03-31 16:56:18] ERROR[3156] netsock2.c: getaddrinfo(“strata8.net”, “(null)”, …): No address associated with hostname
[2014-03-31 16:56:18] WARNING[3156] acl.c: Unable to lookup ‘strata8.net
[2014-03-31 16:56:18] VERBOSE[3156] chan_sip.c: REGISTER 10 headers, 0 lines
[2014-03-31 16:56:18] VERBOSE[3156] chan_sip.c: Reliably Transmitting (no NAT) to (null):
ÿREGISTER sip:strata8.net SIP/2.0
ÿVia: SIP/2.0/UDP 0.0.0.0:5060;branch=z9hG4bK34cb5d2f
ÿMax-Forwards: 70
ÿFrom: sip:[email protected];tag=as4b09bee0
ÿTo: sip:[email protected]
ÿCall-ID: [email protected][::1]
ÿCSeq: 102 REGISTER
ÿUser-Agent: FPBX-2.11.0(11.8.1)
ÿExpires: 120
ÿContact: sip:[email protected]:5060
ÿContent-Length: 0
ÿ
ÿ

Whois is strata8.net?

TruMobility. A colleague recommended them, its our first test/turn-up with them.

-Adam

Well it’s not working and doesn’t exist as far as my view of the internet goes :slight_smile:

I also tried FreePBX Distro 5.211.65 with Asterisk 1.8.26.1, FreePBX 2.11, DAHDI 2.8 and CentOS same problems.

I am able to get this to work with a SIP client (Telephone on OS X w/ the proxy settings enabled) working both calling in/out.

REGISTER sip:strata8.net SIP/2.0 Via: SIP/2.0/UDP 172.16.10.193:55087;rport;branch=z9hG4bKPji4KxLBqioJKXPOuPVpGlkLn4UyM3Gatr Route: Max-Forwards: 70 From: "xxxxxxxxxx" ;tag=ppKNWAwvpbpXJ-6kDTQbqnjAi7JhaEA8 To: "xxxxxxxxxx" Call-ID: N30.fCPfMTLvEKFMxVNMnmu3L-ZF.DFx CSeq: 7854 REGISTER User-Agent: Telephone 1.1.4 Contact: "xxxxxxxxxx" Expires: 300 Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS Content-Length: 0

–end msg–
00:38:59.748 pjsua_acc.c …Acc 0: Registration sent
00:38:59.748 pjsua_acc.c Acc 0: setting online status to 1…
00:38:59.817 pjsua_core.c !.RX 474 bytes Response msg 401/REGISTER/cseq=7854 (rdata0x7f890185b028) from UDP 208.90.249.3:5060:
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP 172.16.10.193:55087;received=67.173.152.217;branch=z9hG4bKPji4KxLBqioJKXPOuPVpGlkLn4UyM3Gatr;rport=55573
From: “xxxxxxxxxx” sip:[email protected];tag=ppKNWAwvpbpXJ-6kDTQbqnjAi7JhaEA8
To: “xxxxxxxxxx” sip:[email protected]
Call-ID: N30.fCPfMTLvEKFMxVNMnmu3L-ZF.DFx
CSeq: 7854 REGISTER
WWW-Authenticate: DIGEST qop=“auth”,nonce=“BroadWorksXhtgr9q97T58r1jkBW”,algorithm=MD5,realm="BroadWorks"
Content-Length: 0

–end msg–
00:38:59.817 pjsua_core.c …TX 850 bytes Request msg REGISTER/cseq=7855 (tdta0x7f890205d600) to UDP 208.90.249.3:5060:
REGISTER sip:strata8.net SIP/2.0
Via: SIP/2.0/UDP 172.16.10.193:55087;rport;branch=z9hG4bKPj6xKUWa8iSxydtz3PH8cMrJSYuzT0XwnN
Route: sip:208.90.249.3;lr
Max-Forwards: 70
From: “xxxxxxxxxx” sip:[email protected];tag=ppKNWAwvpbpXJ-6kDTQbqnjAi7JhaEA8
To: “xxxxxxxxxx” sip:[email protected]
Call-ID: N30.fCPfMTLvEKFMxVNMnmu3L-ZF.DFx
CSeq: 7855 REGISTER
User-Agent: Telephone 1.1.4
Contact: “xxxxxxxxxx” sip:[email protected]:55087;ob
Expires: 300
Allow: PRACK, INVITE, ACK, BYE, CANCEL, UPDATE, INFO, SUBSCRIBE, NOTIFY, REFER, MESSAGE, OPTIONS
Authorization: Digest username=“xxxxxxxxxx”, realm=“BroadWorks”, nonce=“BroadWorksXhtgr9q97T58r1jkBW”, uri=“sip:strata8.net”, response=“a8b45446102cd9a18494aef30f48ea5e”, algorithm=MD5, cnonce=“bradCMjSpnjselGqWZkuwP.HLSYQfU4n”, qop=auth, nc=00000001
Content-Length: 0

–end msg–
00:38:59.908 pjsua_core.c .RX 437 bytes Response msg 200/REGISTER/cseq=7855 (rdata0x7f890185b028) from UDP 208.90.249.3:5060:
SIP/2.0 200 OK
Via: SIP/2.0/UDP 172.16.10.193:55087;received=67.173.152.217;branch=z9hG4bKPj6xKUWa8iSxydtz3PH8cMrJSYuzT0XwnN;rport=55573
From: “xxxxxxxxxx” sip:[email protected];tag=ppKNWAwvpbpXJ-6kDTQbqnjAi7JhaEA8
To: “xxxxxxxxxx” sip:[email protected]
Call-ID: N30.fCPfMTLvEKFMxVNMnmu3L-ZF.DFx
CSeq: 7855 REGISTER
Contact: sip:[email protected]:55087;ob;expires=30;q=0.5
Content-Length: 0
Expires: 30

–end msg–

From your first post

[2014-03-31 16:56:18] WARNING[3156] acl.c: Unable to lookup ‘strata8.net

strata8.net does not exist on my internet, maybe it does on yours :slight_smile: perhaps you should use 773xxxxx:[email protected] to register until they resolve their dns issues.

The strata8.net is only accessible via the proxy which is my issue. Confirmed as working outside of Asterisk with SIP phone client via the proxy. My expectation is that the “outboundproxy” option should cause every type of SIP request to be sent to that address, which doesn’t appear to be working…

Yes, it is your issue as asterisk cannot resolve and hence connect to it, just like the log says, you need to fix your local name service before anything else or as i suggested use it’s ip address.

Okay so added

outboundproxy=208.90.249.3

to
/etc/asterisk/sip_general_custom.conf
and
/etc/asterisk/sip_custom.conf

Global Signalling Settings:

Outb. proxy: 208.90.249.3

now its registered for inbound

strata8.net:5060 N 773xxxxxxx 24 Registered Wed, 02 Apr 2014 00:16:03

Yay!!! Lots of hours later some progress…

Yet now I can’t make outbound calls…
= Unable to create channel of type ‘SIP’ (cause 20 - Subscriber absent)

and inbound requires the anonymous option since the requests are coming from the proxy IP rather the the host = Rejecting unknown SIP connection

Doh…
Why is it so painful to work with a new provider.