Outbound routing

Hi,
I have two outbound routes.One with a sip provider and another with my vega 200g gateway over a E1 line.Inbound is fine but i can not call out with the gateway outbound route.I changed on the same route the ‘Trunk Sequence for Matched Routes’ ,one time using the sip provider and the other time the gateway.I cant understand what is going wroing.The two logs are almost identical.Bellow the logs.
Any help would be great.TIA

NOT WORKING ROUTE

2013-11-12 15:28:39] VERBOSE[4296][C-00000139] pbx.c: – Executing [[email protected]:19] ExecIf(“SIP/2000-0000013c”, “1?Set(CONNECTEDLINE(num,i)=2610995816)”) in new stack
[2013-11-12 15:28:39] VERBOSE[4296][C-00000139] pbx.c: – Executing [[email protected]:20] ExecIf(“SIP/2000-0000013c”, “1?Set(CONNECTEDLINE(name,i)=CID:2610639500)”) in new stack
[2013-11-12 15:28:39] VERBOSE[4296][C-00000139] pbx.c: – Executing [[email protected]:21] GotoIf(“SIP/2000-0000013c”, “0?customtrunk”) in new stack
[2013-11-12 15:28:39] VERBOSE[4296][C-00000139] pbx.c: – Executing [[email protected]:22] Dial(“SIP/2000-0000013c”, “SIP/Vega1/2610995816,300,Tt”) in new stack
[2013-11-12 15:28:39] VERBOSE[4296][C-00000139] netsock2.c: == Using SIP RTP TOS bits 184
[2013-11-12 15:28:39] VERBOSE[4296][C-00000139] netsock2.c: == Using SIP RTP CoS mark 5
[2013-11-12 15:28:39] VERBOSE[4296][C-00000139] app_dial.c: – Called SIP/Vega1/2610995816
[2013-11-12 15:28:39] VERBOSE[2847][C-0000013a] netsock2.c: == Using SIP RTP TOS bits 184
[2013-11-12 15:28:39] VERBOSE[2847][C-0000013a] netsock2.c: == Using SIP RTP CoS mark 5
[2013-11-12 15:28:39] VERBOSE[4297][C-0000013a] pbx.c: – Executing [[email protected]:1] Set(“SIP/Vega1-0000013e”, “GROUP()=OUT_2”) in new stack
[2013-11-12 15:28:39] VERBOSE[4297][C-0000013a] pbx.c: – Executing [[email protected]:2] Goto(“SIP/Vega1-0000013e”, “from-trunk,2610995816,1”) in new stack
[2013-11-12 15:28:39] VERBOSE[4297][C-0000013a] pbx.c: – Goto (from-trunk,2610995816,1)
[2013-11-12 15:28:39] VERBOSE[4297][C-0000013a] pbx.c: – Executing [[email protected]:1] Set(“SIP/Vega1-0000013e”, “__FROM_DID=2610995816”) in new stack
[2013-11-12 15:28:39] VERBOSE[4297][C-0000013a] pbx.c: – Executing [[email protected]:2] NoOp(“SIP/Vega1-0000013e”, “Received an unknown call with DID set to 2610995816”) in new stack
[

WORKING ROUTE

[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] pbx.c: – Executing [[email protected]:15] ExecIf(“SIP/2000-0000016e”, “0?Set(DIAL_TRUNK_OPTIONS=M(setmusic^default)Tt)”) in new stack
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] pbx.c: – Executing [[email protected]:16] ExecIf(“SIP/2000-0000016e”, “0?Set(DIAL_TRUNK_OPTIONS=TtM(confirm))”) in new stack
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] pbx.c: – Executing [[email protected]:17] Macro(“SIP/2000-0000016e”, “dialout-trunk-predial-hook,”) in new stack
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] pbx.c: – Executing [[email protected]:1] MacroExit(“SIP/2000-0000016e”, “”) in new stack
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] pbx.c: – Executing [[email protected]:18] GotoIf(“SIP/2000-0000016e”, “0?bypass,1”) in new stack
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] pbx.c: – Executing [[email protected]:19] ExecIf(“SIP/2000-0000016e”, “1?Set(CONNECTEDLINE(num,i)=2610995816)”) in new stack
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] pbx.c: – Executing [[email protected]:20] ExecIf(“SIP/2000-0000016e”, “1?Set(CONNECTEDLINE(name,i)=CID:2615005177)”) in new stack
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] pbx.c: – Executing [[email protected]:21] GotoIf(“SIP/2000-0000016e”, “0?customtrunk”) in new stack
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] pbx.c: – Executing [[email protected]:22] Dial(“SIP/2000-0000016e”, “SIP/viva/2610995816,300,Tt”) in new stack
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] netsock2.c: == Using SIP RTP TOS bits 184
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] netsock2.c: == Using SIP RTP CoS mark 5
[2013-11-12 15:32:21] VERBOSE[4425][C-0000016a] app_dial.c: – Called SIP/viva/2610995816
[2013-11-12 15:32:22] VERBOSE[4425][C-0000016a] app_dial.c: – SIP/viva-0000016f is ringing
[2013-11-12 15:32:22] VERBOSE[4425][C-0000016a] app_dial.c: – SIP/viva-0000016f is making progress passing it to SIP/2000-0000016e

when you call the vega call seq. 00000139, it returns your call as call seq. 0000013a and the vega. Is that your intension? I assume the vega should send the call out all on it’s own to the tubes and not send it to your pbx.

I saw that too.it looks like the vega is sending the call back.
Is this a vega dialplan issue or an asterisk issue ?.Three days ago the vega was at the office and asterisk at home communicating via vpn.Outbound was ok.The only thing that changed is that i moved the server to the office too.Could this be a network issue in my office ? I also cant see any line in the log of vega regarding the outbound call i am trying.Could this be that the call is not reaching the vega gateway ?
TIA

Just an add on.
The voice message i get from asterisk is ‘The number you have dialed is not in service.Please check the number…’

Yes probably either the Vega programming or the network donfig, check your work :slight_smile: .

I don’t see that part of the call where asterisk plays any file. . .

any help on this issue PLEASE
TIA

Make sure that the module is being recognized in SysAdmin.

What module ?

You have posted nothing of substance to enable anyone to help , you just posted in effect “it doesn’t work, please fix it for me!”

Try adding some flesh to your post maybe ?

Let me take a step back here, I am assuming that you are using the outbound routes module from Schmooze? If not, then you can ignore my previous comment.

Solved.It was my mistake.In the trunk i had put as host the freepbx ip address.Thats why all the calls came back to freepbx.
Thank you all for your time