Outbound routing issue

Hello All,

Fairly new to trixbox / freepbx and need some help with outbound dialing. I am using trixbox CE 2.6.2.2. Have run updates. I have everything set up and functioning. Using X-Lite as my softphone. The problem is getting an incoming call from my extension to my cell phone through the “Follow Me” setup. This setup was working and transferring to the cell correctly until I had a hard drive crash. After the reload I have not been able to get calls to forward to the cell.

I can use the softphone and call my cell with no problem. I can use my cell and call directly to my extension (softphone) with no problem. I can call any of my DID’s from any external line and everything works correctly. When I call from an external line my softphone rings. After 18 seconds of no answer it is supposed to then call my cell using the follow me option. The problem arises when the softphone misses the call, the call goes directly to VM. At this point trixbox sends a text to my cell, and emails me saying I missed a call. I can access and retrieve the VM from the cell.

I can’t figure out what I am missing in the routing that is not allowing the transfer to the cell. I have tried putting the cell phone in the follow me rules with and without the # after the number. My trunk peer details include dtmfmode=RFC2833 and allow=ulaw&g729 I have one outbound route using the dial pattern of X. My outbound route also uses the Trunk sequence referring to my Sip/Account.

After looking at my call logs it seems that dialing from the sip softphone (ext 101) dials out using sip/101-xxxxxxxx plan. This works fine and the calls go through. However, when the IVR tries to use the follow me rules, the call tries to go out as local/[email protected] these calls do not work.

Sorry this is a little long, but wanted you to have app info I felt was needed. If you need any further info, please let me know. Your help is very much appreciated.

Thank you,
Sam

take a look at the trace, where the call to the cell phone is going (or not going) and any status information. That will tell you if it is even trying and if so, where it is ‘failing’ and why.

As I am new to this, how do I trace the route? Is there a log file, or by using the call log?

Thanks

either the log file if logging is set high enough, usually found in /var/log/asterisk/full (set in /etc/asterisk/logger.conf).

Or, and usually more useful, login to the CLI from a terminal (e.g. “asterisk -rvvvvv”) which will set your verbosity to 5, and then watch what happens when a call is made. A bunch of stuff will stream by, some of it will be the clue as to what is up.

I can see the CLI. It is saying something about failed due to congestion. How can I copy and paste the onscreen info? Also looked at log file. Same thing. Accessing remotely through putty.

that would imply that the carrier is telling you that the lines are congested on that trunk. It is likely that you have a carrier that only allows a single call at a time, so if the call is coming in from the outside, that is the single call, when you try to make a new call out, you get congestion back.

Since it is sending you a congestion, it means that if you can put another trunk as a second choice, it should try that.

The trunk has unlimited channels. It worked fine up until the hard drive crashed last friday, After that I could not get the forward to the cell. This trunk is for a small call center and according to the provider the y don’t have a limitation. I believe the problem is in the out going route, but I don’t know what to look for. I have google, read wikis on freepbx and trixbox. Not sure where to go from here.

OK, let me clarify this a little more. I have one sip trunk with no limitation on channels. I have one outbound route that uses the dial patterns of X. and 1NXXNXXXXXX

Peer Details of the trunk are as follows:

username=xxxxxxxxxxxx
secret=abcdefghijklmnop
host=xxxx.xxxxxxx.net
type=peer
insecure=very
dtmfmode=RFC2833
allow=ulaw&g729

I have four inbound DIDs. One goes to my personal extension of 101. It rings for 20 seconds. Voice Mail is setup and functional. VmX Locater is disable.

Follow me settings are:
Initial ring time = 1
Ring Strategy = ringallv2
Ring time = 18
Follow me list= 101 and "My Cell Number#"
Destination if no answer = VM (unavailable)

VM for 101:
Phone Features
Call waiting and do not disturb are not checked
Call forwarding: Unconditional = unchecked
Unavailable = checked
Busy = checked

Follow me:
Enabled = yes
Follow me list = 101 and "My Cell phone"
Ring 101 first for = 4 seconds
Ring follow me list for 18 seconds
Use confirmation is not checked

Email and pager notification is set up and does function.

Any help would be appreciated.

does your provider allow setting the caller id to DIDs that are not yours? Try checking the ‘Never Override Callerid’ box on the trunk.

p_lindheimer, Thank you. I knew it was something simple that I was overlooking. The "Never Override CallerID box was unchecked. Once I checked it everything works as desired.

Thank you so much,
Sam