FreePBX | Register | Issues | Wiki | Portal | Support

Outbound routes for FAX


#1

Experts, I have clarityel provider and looks like they block option to allow ANY CID on the trunk. Currently I have Force TRUNK CID. The problem is I would like to use other number than in Trunk for outgoing faxes.

Inbound is forwarded to extension (which is set on grandstream H812) but outgoing I use with prefix 9 and specific CID. When I choose Allow ANY CIDin the trunk I have I

chan_sip.c: Received response: “Forbidden” from ‘sip:FAXNUMBER@sip.claritytel.com:5160;tag=as5fa7c’
[2019-03-06 01:34:55] VERBOSE[28402][C-00001229] app_dial.c: Everyone is busy/congested at this time (1:0/0/1)

In the extension I would use CIDnumber but I cannot. Is there any way I can fix it in freepbx config or calling claritytel is the only way?

thank you


#2

I know nothing about Claritytel, but virtually all trunk providers allow you to send any DID you have with them (in the same account) and most will allow you to send any ‘verified’ number that is yours.

Does your chan_sip trunk have e.g.
fromuser=2123456789
where that’s the same number you have as your trunk CID?
If not, try adding that to your peer settings, along with
sendrpid=pai

Confirm that you can still call out with Force Trunk CID on, then try turning it off and attempt to send your fax number.

If no luck, get documentation from Claritytel that describes the proper settings for Asterisk.

If they don’t have any, look at an incoming INVITE from them – most providers will accept the same format that they send.


#3

Thank you Stewart1, here is my trunk config:

user=PH NUMB ER
username=PH NUMB ER
authuser=PH NUMB ER
type=peer
host=sip.claritytel.com
fromdomain=sip.claritytel.com
secret=PSWD
insecure=very
transport=udp
qualify=yes
auth=md5
disallow=all
allow=ulaw&g729


#4

I will be adding:

    fromuser=2123456789
    sendrpid=pai

#5

looks like have found their SIP trunk docs for FreePBX:


#6

Wow, they don’t address the issue at all, and don’t even show routing multiple numbers on incoming.

If your fax number is in the same Claritytel account, you should contact them for the proper settings to allow you to select it.

If it’s in a different Claritytel account (a separate trunk with its own username and password), set up an Outbound Route for the fax extension to send fax calls over the other trunk.

If it’s with a different trunking provider, you should probably route your fax calls to them. If that is undesirable (it’s unreliable, expensive, etc.) please provide details.


#7

yes they fixed that so now I can use any CID and works fine. Sending faxes is ok, but receiving … no. When I send fax from other location, or even call in that number I hear fax signal, but fax machine does not receive anything … any thoughts?


#8

ahhhhh Re-INVITE After Fax Tone Detected: needs to be disabled on ATA box