FreePBX | Register | Issues | Wiki | Portal | Support

Outbound Routes: Cannot download local patterns


#1

When I try do download local patterns in the outbound routes module (from localcallingguide.com), I get a banner on top of the screen that says “Something went wrong with the download”

All modules are up to date.

Tried the same on other systems and I get the same error.

Anyone else has the same issue ?


#2

I still have this issue. Brand new system, updated. I try to generate the patterns with the following options:

NPA:450
NXX:424
7, 10 and 11 digits patterns selected

As soon as I click on “Generate Routes”, I get a banner on the top of the screen that says “Someting went wrong with the download”.

Anyone else has this issue ?


#3

Make sure all and any firewall is disabled, but it is sourced from a third party which by a quick check is currently down . . . .


#4

Dang !!! I’m pretty sure you’re right ! Checking this right now.


#5

Ok, I tried adding www.localcallingguide.com to the “local” zone in the Firewall module (a bit like Let’s Encrypt’s setup does) but it still doesn’t work. I’ll try to find the firewall’s logs to see if the connection really get’s blocked.


(Tom Ray) #6

Wouldn’t doing:

Prepend: Prefix: Pattern: 450242XXXX
Prepend: 1 Prefix: Pattern: 450242XXXX
Prepend: 1450 Prefix: Pattern: 242XXXX

Be much better than downloading and installing about 30000 routes to achieve that? There is rarely a need to worry about the subscriber (XXXX) portion of the number as it is only used for “final user routing” (or used to be). All the routing/cost charges are based on the 450424 part of the the number.

There is absolutely no need to have a route for all 10,000 XXXX’s that could exist on an NPANXX block. And if you want a route for 11, 10 and 7 that means 30,000 routes.


#7

Tried with firewall disabled and stick no luck. Dicko you said that the third party was down ? What did you mean by that ? www.localcallingguide.com seems to be up.


#8

Need this for long distance management… we have 2 providers and long distances must be sent to one of them only.


(Tom Ray) #9

OK, but as I said the Long Distance part of the call is determined by 450424 the XXXX portion of the call is not used for that. So if you need to specifically route 450424 to a specific provider, the outbound pattern matches I gave you would do just fine.

It just would mean you would need an Outbound Route with three pattern matches for each NPANXX to support 7 digit dialing and prepending the right NPANXX to the 7 digit pattern.


#10

I explained wong:

We have 2 providers:

  • VOIP.ms charges by the minute, unlimited numbers of channels
  • Babytel has unlimited minutes for local calls only, limited to 2 channels

So what I need is (I did it in the past and it worked fine):
Any number that is local to 450424 is routed to BabyTEL, since we have unlimited minutes. If both channels are busy, the call falls back to VOIP.ms
If the call is not local, it goes through VOIP.ms because their minute rate is cheaper than BabyTEL’s long distance rate.


(Tom Ray) #11

OK so then you make an Outbound Route that is called “Local Calling” in it, you put those three pattern matches in so no matter how a number to 450424XXXX is dialed, this route will catch it and send it out BabyTel.

Update: You have the BabyTel trunk first and then the Voip.ms trunk second so it can rollover.

You create a second Outbound Route that matches 1NXXNXXXXXX and NXXNXXXXXX since this is for “long distance”. You send calls out this route to Voip,ms

Like I said call the first route “Local” the second route “Long Distance” the make the “Local” route the first in the list and “Long Distance” after that.

Then of course make your 911 route and push it to whichever provider is supplying the DIDs and thus 911.

No need for 1,000’s of routes or matches.


#12

yep it looks like they have cranked up their ssl auths, you will need to do it manually or wait for a module update.


#13

It’s not that simple. Local calls are not only 450424XXXX. A lot of other 450XXXXXXX 438XXXXXXX and 514XXXXXXX are also local (Montreal) so that is the reason why I need to be able to download the list of patterns.


#14

Thanks Dicko !


#15

Blaze,

Here’s the list of patterns that are considered local to 450424XXXX
https://localcallingguide.com/lprefix.php?exch=174810

As you can see, there is quite a few !


(Tom Ray) #16

JFC. Stop making this harder than it needs to be. Now this is based on just area codes? Then you need to make a “Local - 11/10 Digits” and in that you take the 11 / 10 digit matches I gave you and you do it for each of the NPAs

450, 579, 438, 514. So it’s like 8 pattern matches for that. You won’t be able to support 7 digit dialing over multiple NPAs.


(Tom Ray) #17

@chrischevy What you need to be looking at is not the NXX part of that list but the Rate Center parts of that list. You should see what Rate Centers are local to your Rate Center. You’ll find that pretty almost all of those NXX’s you’re concerned about all live in the 12 Rate Centers in that area and you can get away with just the NPA matching because it’s all “Local” to your Rate Center (being on of the 12)

It would be better to spend a few minutes confirming that ever NPANXX you need is in a local Rate Center and thus a “local” call so you don’t need to make 100’s or 1000’s of matches.

All your “local” NPANXX’s live in these Rate Centers and all the NXX’s for those NPAs are in those rate centers, so again just using the NPAXXXXXXX match will get the same results.

The only time you would need another specific match is if for some reason the NPANXX list has an NPANXX that isn’t in one of those Rate Centers but by my eyeballing it all, that’s not the case.


#18

Thanks for helping but I really need to be able to download the whole list.
I need exactly 1165 patterns to achieve what I want. I won’t create them manually.


(Tom Ray) #19

You really don’t but if you believe you do then OK. You’re basically saying “I’m good with having 10x’s the routes loading into memory than I need”.

Again, all of 450NXXXXXX, 579NXXXXXX, 438NXXXXXX, and 514NXXXXXX exist in those 12 Rate Centers and calls between those Rate Centers are considered local. All you need is a 11 and 10 digit pattern for each of those and you’re covered.

Even if there are some outliers that would still mean waaay less pattern matches to process than what you are looking to do. You’re missing the forest for the trees.


(Benoit Lambert) #20

Getting the same issue on a fully updated distro 14. Opened up an issue for it: https://issues.freepbx.org/browse/FREEPBX-18670