Outbound Route with PIN Set doesn't play ringing tone for caller

I have an outbound route that dials an external number with a PIN set configured. This is working just fine, and after entering a PIN the external number is dialled and can answer the call. I don’t actually know if having a “PIN Set” configured makes any difference, but thought I’d mention it for completeness.

The problem is that the caller doesn’t get any feedback at all while the external number is ringing. The only hear silence upon entering a valid PIN, which obviously causes a lot of confusion. The only setting on the outbound route that seems relevant is “Music On Hold?”, but I’ve tried setting that to my “default” music on hold group and it doesn’t appear to make any difference.

Is anyone able to point me in the direction of whatever I’m missing to give the caller some sort of feedback while the external number is ringing?

FreePBX with Asterisk 16.11.1 on 12.7.8-2008-1.sng7.

For the outbound trunk, try setting Inband Progress to Yes.

If that doesn’t help, please report:

Does temporarily removing the PIN set make a difference?
Are there other Outbound Routes (with or without PIN set) using the same trunk and working properly?
Trunk type (pjsip, chan_sip, etc.)?

@Stewart1 Thanks for your assistance, it’s taken me some time to try a couple of things:

  1. I was originally using chan_sip, tried setting “inband progress” to yes with it, made no difference.
  2. Tried removing the PIN set, no difference.
  3. Bit the bullet and created all trunks again as pjsip (took some time to iron out), no difference.
  4. Turned “inband progress” on for pjsip, no difference.
  5. Have tried setting the outbound trunk to use a trunk from a different provider, no difference.

After all that, I went back to the start and looked at how I was using the outbound route in the first place. I have a ring group that uses an external number as the extension, and that external number matches a dial pattern on the outbound route with the PIN set that I thought was the problem. The ring group has a “Play Music On Hold” setting, and that turned out to be culprit. The value was set to “none”, and after changing it to “Ring”, the caller hears ringing while waiting for the external number to pick up.

Now working as intended, so hope this might help anyone else with a similar issue in future. Troubleshooting did prompt me to get around to upgrading from chan_sip to pjsip at last, so it wasn’t all wasted effort.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.